Subject: pg_restore listing

From: Pavel Golub <[email-masked]>
Date: Tue, 29 Sep 2009 12:01:57 +0300

Hello, pgsql-docs.

I think it would be nice to update the listing file example (and
explanation of listing) at
http://www.postgresql.org/docs/8.4/static/app-pgrestore.html

Now it looks like:

;
; Archive created at Fri Jul 28 22:28:36 2000
;     dbname: mydb
;     TOC Entries: 74
;     Compression: 0
;     Dump Version: 1.4-0
;     Format: CUSTOM
;
;
; Selected TOC Entries:
;
2; 145344 TABLE species postgres
3; 145344 ACL species
...

But modern utilities output looks a bit different:

;
; Archive created at Mon Sep 14 13:55:39 2009
;     dbname: DBDEMOS
;     TOC Entries: 81
;     Compression: 9
;     Dump Version: 1.10-0
;     Format: CUSTOM
;     Integer: 4 bytes
;     Offset: 8 bytes
;     Dumped from database version: 8.3.5
;     Dumped by pg_dump version: 8.3.8
;
;
; Selected TOC Entries:
;
3; 2615 2200 SCHEMA - public pasha
1861; 0 0 COMMENT - SCHEMA public pasha
1862; 0 0 ACL - public pasha
317; 1247 17715 TYPE public composite pasha
319; 1247 25899 DOMAIN public domain0 pasha

-- 
With best wishes,
 Pavel                          mailto:[email-masked]

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 22 Feb 2010 19:21:25 -0500 (EST)

Agreed, patch attached and applied.  Thanks.

---------------------------------------------------------------------------

Pavel Golub wrote:
> Sent via pgsql-docs mailing list ([email-masked])
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-docs

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com
  PG East:  http://www.enterprisedb.com/community/nav-pg-east-2010.do
  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/ref/pg_restore.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/ref/pg_restore.sgml,v
retrieving revision 1.84
diff -c -c -r1.84 pg_restore.sgml
*** doc/src/sgml/ref/pg_restore.sgml	19 Feb 2010 14:36:45 -0000	1.84
--- doc/src/sgml/ref/pg_restore.sgml	23 Feb 2010 00:20:17 -0000
***************
*** 759,786 ****
     The listing file consists of a header and one line for each item, e.g.:
  <programlisting>
  ;
! ; Archive created at Fri Jul 28 22:28:36 2000
! ;     dbname: mydb
! ;     TOC Entries: 74
! ;     Compression: 0
! ;     Dump Version: 1.4-0
  ;     Format: CUSTOM
  ;
  ;
  ; Selected TOC Entries:
  ;
! 2; 145344 TABLE species postgres
! 3; 145344 ACL species
! 4; 145359 TABLE nt_header postgres
! 5; 145359 ACL nt_header
! 6; 145402 TABLE species_records postgres
! 7; 145402 ACL species_records
! 8; 145416 TABLE ss_old postgres
! 9; 145416 ACL ss_old
! 10; 145433 TABLE map_resolutions postgres
! 11; 145433 ACL map_resolutions
! 12; 145443 TABLE hs_old postgres
! 13; 145443 ACL hs_old
  </programlisting>
     Semicolons start a comment, and the numbers at the start of lines refer to the
     internal archive ID assigned to each item.
--- 759,783 ----
     The listing file consists of a header and one line for each item, e.g.:
  <programlisting>
  ;
! ; Archive created at Mon Sep 14 13:55:39 2009
! ;     dbname: DBDEMOS
! ;     TOC Entries: 81
! ;     Compression: 9
! ;     Dump Version: 1.10-0
  ;     Format: CUSTOM
+ ;     Integer: 4 bytes
+ ;     Offset: 8 bytes
+ ;     Dumped from database version: 8.3.5
+ ;     Dumped by pg_dump version: 8.3.8
  ;
  ;
  ; Selected TOC Entries:
  ;
! 3; 2615 2200 SCHEMA - public pasha
! 1861; 0 0 COMMENT - SCHEMA public pasha
! 1862; 0 0 ACL - public pasha
! 317; 1247 17715 TYPE public composite pasha
! 319; 1247 25899 DOMAIN public domain0 pasha
  </programlisting>
     Semicolons start a comment, and the numbers at the start of lines refer to the
     internal archive ID assigned to each item.