Subject: Improve pg_restore docs

From: Mike Toews <[email-masked]>
Date: Mon, 29 Jun 2009 11:15:26 -0700

Hi,

 From a quick discussion on hackers 
(http://archives.postgresql.org/pgsql-hackers/2009-06/msg01434.php), it 
appears the documentation can improve for pg_restore.

I've prepared some quick diff output from 
pgsql/doc/src/sgml/ref/pg_restore.sgml for some changes that I think 
would help. Note that I'm not entirely sure about the default namespace 
from default_path .. please verify this before accepting. Edit as necessary.

291c291,292
<         specific table.
---
 >         specific table.  The default is taken from the
 >         <envar>default_path</envar> variable.
379c380,382
<         Restore definition and/or data of named table only.
---
 >         Restore definition and/or data of named table only. This can be
 >         combined with the <option>-n</option> option to restore a table
 >         from a specific schema.

Thanks,

-Mike

---

From: Greg Smith <[email-masked]>
Date: Mon, 29 Jun 2009 14:25:26 -0400 (EDT)

On Mon, 29 Jun 2009, Mike Toews wrote:

> pgsql/doc/src/sgml/ref/pg_restore.sgml for some changes that I think would 
> help.

The standard way to submit patches here is to attach a file with a full 
context diff (diff -c) to the message, rather than putting it inline or 
including just the changes.  The idea is to make it easy for the 
committers to grab your patch and apply it.

--
* Greg Smith [email-masked] http://www.gregsmith.com Baltimore, MD

---

From: Mike Toews <[email-masked]>
Date: Mon, 29 Jun 2009 11:31:48 -0700

Greg Smith wrote:
> The standard way to submit patches here is to attach a file with a 
> full context diff (diff -c) to the message, rather than putting it 
> inline or including just the changes.  The idea is to make it easy for 
> the committers to grab your patch and apply it.

Part of my hesitation in attaching the patch is that I'm on a Windows 
computer (be aware of CRLF line endings in the attached). Apply to 
pgsql/doc/src/sgml/ref/pg_restore.sgml

-Mike
291c291,292
<         specific table.
---
379c380,382

---

From: Greg Smith <[email-masked]>
Date: Mon, 29 Jun 2009 14:34:31 -0400 (EDT)

On Mon, 29 Jun 2009, Mike Toews wrote:

> Apply to pgsql/doc/src/sgml/ref/pg_restore.sgml

The main point I was trying to make is that we want the whole patch, not 
just the change.  A standard diff patch will include what file name it is 
supposed to apply to as part of its header.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 24 Feb 2010 11:28:44 -0500 (EST)

>  >         combined with the <option>-n</option> option to restore a table

I have applied a modified version of your second change to our
documentation.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com
  PG East:  http://www.enterprisedb.com/community/nav-pg-east-2010.do
  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/ref/pg_restore.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/ref/pg_restore.sgml,v
retrieving revision 1.85
diff -c -c -r1.85 pg_restore.sgml
*** doc/src/sgml/ref/pg_restore.sgml	23 Feb 2010 00:21:19 -0000	1.85
--- doc/src/sgml/ref/pg_restore.sgml	24 Feb 2010 16:27:14 -0000
***************
*** 377,383 ****
        <term><option>--table=<replaceable class="parameter">table</replaceable></option></term>
        <listitem>
         <para>
!         Restore definition and/or data of named table only.
         </para>
        </listitem>
       </varlistentry>
--- 377,384 ----
        <term><option>--table=<replaceable class="parameter">table</replaceable></option></term>
        <listitem>
         <para>
!         Restore definition and/or data of named table only.  This can be
!         combined with the <option>-n</option> option to specify a schema.
         </para>
        </listitem>
       </varlistentry>