Subject: libpq-example.html needs to use <> includes

From: Josh Berkus <[email-masked]>
Date: Wed, 24 Feb 2010 17:37:30 -0800

All,

The libpq-example is using local includes for libpq-fe, instead of
library includes:

#include "libpq-fe.h"

I can't think of a single good reason for this, is there one?

--Josh Berkus

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 26 Feb 2010 22:41:36 -0500 (EST)

> I can't think of a single good reason for this, is there one?

Agreed, fixed with the attached, applied patch.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com
  PG East:  http://www.enterprisedb.com/community/nav-pg-east-2010.do
  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/libpq.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/libpq.sgml,v
retrieving revision 1.302
diff -c -c -r1.302 libpq.sgml
*** doc/src/sgml/libpq.sgml	24 Feb 2010 15:54:31 -0000	1.302
--- doc/src/sgml/libpq.sgml	27 Feb 2010 03:40:36 -0000
***************
*** 7010,7016 ****
   */
  #include <stdio.h>
  #include <stdlib.h>
! #include "libpq-fe.h"
  
  static void
  exit_nicely(PGconn *conn)
--- 7010,7016 ----
   */
  #include <stdio.h>
  #include <stdlib.h>
! #include <libpq-fe.h>
  
  static void
  exit_nicely(PGconn *conn)
***************
*** 7158,7164 ****
  #include <string.h>
  #include <errno.h>
  #include <sys/time.h>
! #include "libpq-fe.h"
  
  static void
  exit_nicely(PGconn *conn)
--- 7158,7164 ----
  #include <string.h>
  #include <errno.h>
  #include <sys/time.h>
! #include <libpq-fe.h>
  
  static void
  exit_nicely(PGconn *conn)
***************
*** 7296,7302 ****
  #include <stdlib.h>
  #include <string.h>
  #include <sys/types.h>
! #include "libpq-fe.h"
  
  /* for ntohl/htonl */
  #include <netinet/in.h>
--- 7296,7302 ----
  #include <stdlib.h>
  #include <string.h>
  #include <sys/types.h>
! #include <libpq-fe.h>
  
  /* for ntohl/htonl */
  #include <netinet/in.h>