Subject: typo in release note

From: Fujii Masao <[email-masked]>
Date: Thu, 10 Jun 2010 17:00:40 +0900

Hi,

The release note says "Allow continuous archive (WAL) files
to be streamed to a standby system" about SR. But no archive
files are streamed in SR. So we should get rid of the word
"archive" from that sentence? Here is the patch.

Regards,

-- 
Fujii Masao
NIPPON TELEGRAPH AND TELEPHONE CORPORATION
NTT Open Source Software Center

---

From: Robert Haas <[email-masked]>
Date: Thu, 10 Jun 2010 09:06:34 -0400

> "archive" from that sentence? Here is the patch.

I don't think that reads very well.  Possibly we could remove
"continuous archive" as a whole, but I don't think we can remove one
word and keep the other.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise Postgres Company

---

From: Tom Lane <[email-masked]>
Date: Thu, 10 Jun 2010 10:16:23 -0400

> "continuous archive" as a whole, but I don't think we can remove one

I'm inclined to think that "continuous archiving" was meant.  At least
that's the phrase that is used in chapter 24.

			regards, tom lane

---

From: Robert Haas <[email-masked]>
Date: Thu, 10 Jun 2010 10:29:59 -0400

> that's the phrase that is used in chapter 24.

Yeah, probably - but I think what Fujii-san is concerned about is
whether streaming replication is a subset of continuous archiving -
the files never actually get "archived".

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 30 Jun 2010 22:33:19 -0400 (EDT)

Robert Haas wrote:
> >> I don't think that reads very well. ?Possibly we could remove
> > I'm inclined to think that "continuous archiving" was meant. ?At least

Fujii-san is absolutely right.  The original wording assumed streaming
replication and hot standby were a subset of continuous archiving, but I
later realized that you do not need to enable continuous archiving to do
use them, particularly with a sufficiently large wal_keep_segments:

	http://momjian.us/main/blogs/pgblog/2010.html#June_16_2010

Attached patch applied.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + None of us is going to be here forever. +
Index: doc/src/sgml/release-9.0.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/release-9.0.sgml,v
retrieving revision 2.37
diff -c -c -r2.37 release-9.0.sgml
*** doc/src/sgml/release-9.0.sgml	30 Jun 2010 14:25:24 -0000	2.37
--- doc/src/sgml/release-9.0.sgml	1 Jul 2010 02:29:52 -0000
***************
*** 398,404 ****
      <itemizedlist>
       <listitem>
        <para>
!        Allow continuous archive standby systems to accept read-only queries
         (Simon Riggs, Heikki Linnakangas)
        </para>
  
--- 398,404 ----
      <itemizedlist>
       <listitem>
        <para>
!        Allow a standby system to accept read-only queries
         (Simon Riggs, Heikki Linnakangas)
        </para>
  
***************
*** 412,418 ****
  
       <listitem>
        <para>
!        Allow continuous archive (<acronym>WAL</>) files to be streamed to a
         standby system (Fujii Masao, Heikki Linnakangas)
        </para>
  
--- 412,418 ----
  
       <listitem>
        <para>
!        Allow write-ahead log (<acronym>WAL</>) files to be streamed to a
         standby system (Fujii Masao, Heikki Linnakangas)
        </para>