Subject: pdf-visible links into config.gsml from high-availability.sgml

From: "Erik Rijkers" <[email-masked]>
Date: Tue, 19 Jul 2011 12:29:59 +0200

Reading about synchronous replication in a paper copy of .pdf high-availability.sgml pages, I
missed the information in config.sgml. There /is/ a (single) link, but it's not visible in the
pdf; even with the pdf on-screen it is only noticable only with MouseOver.

I think it would be good to make two explicit, visible links, as attached, to connect the two main
places with sync-repl information.  Then there will be a clear "See Section ..." reference.

(against today's REL9_1_STABLE)

thanks,

Erik Rijkers

--- doc/src/sgml/high-availability.sgml.orig	2011-07-19 11:23:06.000000000 +0200
+++ doc/src/sgml/high-availability.sgml	2011-07-19 11:25:38.000000000 +0200
@@ -935,7 +935,9 @@
     <xref linkend="guc-synchronous-standby-names"> must be set to
     a non-empty value.  <varname>synchronous_commit</> must also be set to
     <literal>on</>, but since this is the default value, typically no change is
-    required.  This configuration will cause each commit to wait for
+    required. (See <xref linkend="runtime-config-wal-settings"> and 
+    <xref linkend="runtime-config-replication-master">.)
+    This configuration will cause each commit to wait for
     confirmation that the standby has written the commit record to durable
     storage, even if that takes a very long time.
     <varname>synchronous_commit</> can be set by individual

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 3 Aug 2012 16:33:22 -0400

> +++ doc/src/sgml/high-availability.sgml	2011-07-19 11:25:38.000000000 +0200

OK, patch applied to 9.2 and head.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +