Subject: Excuse me! Could i to ask a question?

From: 劉維毅 <[email-masked]>
Date: Fri, 14 Dec 2012 13:05:21 +0900

Hi!
It's very sorry to disrupted you, but could you help me?
I am a programmer, and i want to use Postgresql 9.2.2 to store my 
applications' data. I had to
build a trigger wich based on Database level( When the database startup 
, this trigger will fired and
executed.),while i found there are not defined database-level trigger in 
postgresql. I read the doc but could
not found methods that could replaced triggers based on database.
Coud you give me a hand? Are there any tables auto update when 
postgresql  server startup,  in this
way i could create a trigger on this table when server startup!
Thanks a lot and best regards!
Edward
mailto:[email-masked]
---------------------------------------------------------------------------------------------------
Confidentiality Notice: The information contained in this e-mail and any accompanying attachment(s) 
is intended only for the use of the intended recipient and may be confidential and/or privileged of 
Neusoft Corporation, its subsidiaries and/or its affiliates. If any reader of this communication is 
not the intended recipient, unauthorized use, forwarding, printing,  storing, disclosure or copying 
is strictly prohibited, and may be unlawful.If you have received this communication in error,please 
immediately notify the sender by return e-mail, and delete the original message and all copies from 
your system. Thank you. 
---------------------------------------------------------------------------------------------------

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: "Kevin Grittner" <[email-masked]>
Date: Mon, 17 Dec 2012 09:06:23 -0500

> way i could create a trigger on this table when server startup!

It's not entirely clear what you want or why.  Do you want this to
run when the PostgreSQL cluster (collection of databases running
under the control of a single postmaster process) is available for
connections, when there is the first connection to the cluster
(which creates a backend server process), when there is the first
connection to some particular database in the cluster, or for each
connection? What sorts of things do you need it to do? What is the
problem you are trying to solve?

If you want it once per cluster start, the easiest way would be to
use a custom service script to stop and start the server, which
could run a script. Other timings would need other solutions, but
it would help to know what the problem is that you are trying to
solve.

-Kevin