Subject: seek advice about translation management

From: "[email-masked]" <[email-masked]>
Date: Fri, 1 Nov 2013 13:21:44 +0800

Hi, everyone !
     I'm Jasmine Liu , from China.
    Now my group want to translate PostgreSQL 9.3.1 documentation 
into Chinese. And we get a few problems:
    1, How to identify the difference between varying documentation ?
    2, How to manage documentation of different version ?
    3, How to coordinate multiple translators to complete the translation?
    4, How to convert sgml to html independently? and how to convert html to sgml?
    5, How did you manage your documentation translation?
    If you have any experience or ideas about transaltion management,
please write to me, I'm looking forward to your reply.
    Thanks and best wishes!
    
    Yours,
    Jasmine Liu
    November 1st, 2013

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 18 Nov 2013 12:35:33 -0500

> please write to me, I'm looking forward to your reply.

Good questions.  I would reach out to the other groups doing
translations, like Japanese and French.  They might have their own email
lists.  Unfortunately, I can't seem to find them.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Guillaume Lelarge <[email-masked]>
Date: Mon, 18 Nov 2013 22:32:42 +0100

Hi,

I'll try to answer what I can.

> >     1, How to identify the difference between varying documentation ?

I'm using git diff to get the diff between two releases (minor or
major).

> >     2, How to manage documentation of different version ?

I use one branch for each release on the git repository.

> >     3, How to coordinate multiple translators to complete the translation?

Much harder :)

I usually do the coordination between each. I put a wiki page on github,
with the list of files to updates and a link to the diff. Each
translator put their name in front of the file he wants to translate.

> >     4, How to convert sgml to html independently? and how to convert html to

Don't know. We're using xml.

> >     5, How did you manage your documentation translation?

Can you be a bit more precise?

> lists.  Unfortunately, I can't seem to find them.

Thanks, Bruce. I completely forgot to answer this mail when I first saw
it.

-- 
Guillaume
http://blog.guillaume.lelarge.info
http://www.dalibo.com