Subject: readability tutorial example in pdf

From: "Erik Rijkers" <[email-masked]>
Date: Sat, 4 May 2013 23:00:26 +0200

The attached patch breaks code-example into two lines.

In the pdf (A4) version this line is truncated by several words, making a tutorial example
incomprehensible.

(The line-break also shows up in the html vrsion but does not look particularly ugly there)

Thanks,

Erik Rijkers

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 4 Dec 2013 10:03:57 -0500

> (The line-break also shows up in the html vrsion but does not look particularly ugly there)

Agreed.  I ended up splitting it into three lines;  applied patch
attached.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +
diff --git a/doc/src/sgml/advanced.sgml b/doc/src/sgml/advanced.sgml
new file mode 100644
index 3c067d5..1e45511
*** a/doc/src/sgml/advanced.sgml
--- b/doc/src/sgml/advanced.sgml
*************** SELECT depname, empno, salary, avg(salar
*** 389,395 ****
      order in which the rows are output.)  Here is an example:
  
  <programlisting>
! SELECT depname, empno, salary, rank() OVER (PARTITION BY depname ORDER BY salary DESC) FROM empsalary;
  </programlisting>
  
  <screen>
--- 389,397 ----
      order in which the rows are output.)  Here is an example:
  
  <programlisting>
! SELECT depname, empno, salary,
!        rank() OVER (PARTITION BY depname ORDER BY salary DESC)
! FROM empsalary;
  </programlisting>
  
  <screen>