Subject: documentation: json processing table pasto

From: rudolf <[email-masked]>
Date: Sun, 13 Apr 2014 11:36:08 +0200

(Please CC me the reply, I'm not subscribed to the list.)

Hi,

the table 
http://www.postgresql.org/docs/devel/static/functions-json.html#FUNCTIONS-JSON-PROCESSING-TABLE 
contains two json_extract_path_text() entries, where the second should 
be the jsonb variant.

Regards,

r.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 16 Apr 2014 11:25:08 -0400

On Sun, Apr 13, 2014 at 11:36:08AM +0200, rudolf wrote:
> the table http://www.postgresql.org/docs/devel/static/functions-json.html#FUNCTIONS-JSON-PROCESSING-TABLE
> contains two json_extract_path_text() entries, where the second
> should be the jsonb variant.

Fixed with the attached patch.  Thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +
diff --git a/doc/src/sgml/func.sgml b/doc/src/sgml/func.sgml
new file mode 100644
index 0809a6d..1759c88
*** a/doc/src/sgml/func.sgml
--- b/doc/src/sgml/func.sgml
*************** table2-mapping
*** 10536,10542 ****
        </row>
        <row>
         <entry><para><literal>json_extract_path_text(from_json json, VARIADIC path_elems text[])</literal>
!          </para><para><literal>json_extract_path_text(from_json json, VARIADIC path_elems text[])</literal>
         </para></entry>
         <entry><type>text</type></entry>
         <entry>
--- 10536,10542 ----
        </row>
        <row>
         <entry><para><literal>json_extract_path_text(from_json json, VARIADIC path_elems text[])</literal>
!          </para><para><literal>json_extract_path_text(from_json jsonb, VARIADIC path_elems text[])</literal>
         </para></entry>
         <entry><type>text</type></entry>
         <entry>