Subject: cleanup of ./src/test/isolation/README

From: Josh Kupershmidt <[email-masked]>
Date: Thu, 12 May 2011 19:28:25 -0400

Some grammar cleanup for ./src/test/isolation/README is attached.

Josh
diff --git a/src/test/isolation/README b/src/test/isolation/README
index ee94081..087ac27 100644
*** a/src/test/isolation/README
--- b/src/test/isolation/README
*************** Isolation tests
*** 4,10 ****
  ===============
  
  This directory contains a set of tests for the serializable isolation level.
! Testing isolation requires running multiple overlapping transactions, so
  which requires multiple concurrent connections, and can't therefore be
  tested using the normal pg_regress program.
  
--- 4,10 ----
  ===============
  
  This directory contains a set of tests for the serializable isolation level.
! Testing isolation requires running multiple overlapping transactions,
  which requires multiple concurrent connections, and can't therefore be
  tested using the normal pg_regress program.
  
*************** file with a custom syntax, described in
*** 13,22 ****
  
  isolationtester is program that uses libpq to open multiple connections,
  and executes a test specified by a spec file. A libpq connection string
! to specify the server and database to connect to, the defaults derived from
  environment variables are used otherwise.
  
! pg_isolation_regress is a tool identical to pg_regress, but instead of using
  psql to execute a test, it uses isolationtester.
  
  To run the tests, you need to have a server up and running. Run
--- 13,22 ----
  
  isolationtester is program that uses libpq to open multiple connections,
  and executes a test specified by a spec file. A libpq connection string
! specifies the server and database to connect to; defaults derived from
  environment variables are used otherwise.
  
! pg_isolation_regress is a tool similar to pg_regress, but instead of using
  psql to execute a test, it uses isolationtester.
  
  To run the tests, you need to have a server up and running. Run
*************** session "<name>"
*** 58,64 ****
  
  permutation "<step name>" ...
  
!   A permutation line specifies a list of steps that are ran in that order.
    If no permutation lines are given, the test program automatically generates
    all possible overlapping orderings of the given sessions.
  
--- 58,64 ----
  
  permutation "<step name>" ...
  
!   A permutation line specifies a list of steps that are run in that order.
    If no permutation lines are given, the test program automatically generates
    all possible overlapping orderings of the given sessions.

---

From: Tom Lane <[email-masked]>
Date: Tue, 24 May 2011 18:52:45 -0400

> Some grammar cleanup for ./src/test/isolation/README is attached.

Applied, thanks.

			regards, tom lane