Subject: libpq "service" parameter not documented as not allowed inside a pg_service file

From: David Johnston <[email-masked]>
Date: Fri, 19 Dec 2014 18:52:42 -0700

While the fact that you cannot do:

[service_template]
host=xxx.xxx.xxx.xxx

[service_db1]
dbname=db1
service=service_template

seems obvious there is nothing in the documentation that says this is
prohibited; and attempting a simple alias entry:

[realentry]
user=not_system_user
dbname=whatever

[aliasentry]
service=realentry

psql "service=aliasentry"

results in the error:

FATAL:  role "system-user" does not exist

Version 9.3

SIDE NOTE: between the "FATAL:" and the word "role" are two spaces instead
of what probably should be one.

Anyway,

http://www.postgresql.org/docs/9.4/static/libpq-pgservice.html

says that "[...] and the parameters are connection parameters; [...]

and one of those parameters is "service"

http://www.postgresql.org/docs/9.4/static/libpq-connect.html#LIBPQ-PARAMKEYWORDS

I would suggest:

"connection parameters; see Section 31.1.2 for a list but note that you may
not include the "service" parameter within the pg_service file (i.e.,
aliases are not allowed).

Thoughts?

David J.

P.S.

Any chance on actually making this work?  The recent comment about "\c
service=name" not working properly seems to fall into the same category so
maybe fix them both at the same time - though the other issue is probably
more of a bug while this is a feature request (unless the interplay is
non-trivial)...

I'm going to link to this post and add a comment to that thread.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 1 Apr 2015 16:52:48 -0400

> prohibited; and attempting a simple alias entry:

I have developed the attached patch to warn users that nesting of
service entries is not supported.  I prefer code warnings over
documentation because the user gets the warning as soon as they try
something, rather than having to hunt in the documentation.  I don't
think this issue has come up enough to warrant a doc mention too though.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +
diff --git a/src/interfaces/libpq/fe-connect.c b/src/interfaces/libpq/fe-connect.c
new file mode 100644
index e2a06b3..083e6df
*** a/src/interfaces/libpq/fe-connect.c
--- b/src/interfaces/libpq/fe-connect.c
*************** parseServiceFile(const char *serviceFile
*** 4061,4066 ****
--- 4061,4076 ----
  				}
  				*val++ = '\0';
  
+ 				if (strcmp(key, "service") == 0)
+ 				{
+ 					printfPQExpBuffer(errorMessage,
+ 									  libpq_gettext("nested service specifications not supported in service file \"%s\", line %d\n"),
+ 									  serviceFile,
+ 									  linenr);
+ 					fclose(f);
+ 					return 3;
+ 				}
+ 
  				/*
  				 * Set the parameter --- but don't override any previous
  				 * explicit setting.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 8 Apr 2015 10:26:35 -0400

> think this issue has come up enough to warrant a doc mention too though.

Patch applied.  Thanks for the report.