Subject: Minor typo in rules.sgml

From: Dean Rasheed <[email-masked]>
Date: Sun, 14 Jun 2015 10:49:04 +0100

There's a minor grammatical typo in the description of leakproof
functions (going back to 9.2).
Patch attached.

Regards,
Dean
diff --git a/doc/src/sgml/rules.sgml b/doc/src/sgml/rules.sgml
new file mode 100644
index cb5c8fc..720f976
--- a/doc/src/sgml/rules.sgml
+++ b/doc/src/sgml/rules.sgml
@@ -2162,7 +2162,7 @@ CREATE VIEW phone_number WITH (security_
     <literal>LEAKPROOF</literal> to be pushed down, as they never receive data
     from the view.  In contrast, a function that might throw an error depending
     on the values received as arguments (such as one that throws an error in the
-    event of overflow or division by zero) are not leak-proof, and could provide
+    event of overflow or division by zero) is not leak-proof, and could provide
     significant information about the unseen rows if applied before the security
     view's row filters.
 </para>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 8 Aug 2015 20:41:06 -0400

> functions (going back to 9.2).

Patch applied and backpatched to 9.5 --- thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +