Subject: effective_io_concurrency and SSDs

From: Bruce Momjian <[email-masked]>
Date: Thu, 18 Feb 2016 19:19:57 -0500

I have created the attached doc patch to update effective_io_concurrency
to more accurately cover SSDs.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I. As I am, so you will be. +
+ Roman grave inscription                             +
diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
new file mode 100644
index a09ceb2..feb3777
*** a/doc/src/sgml/config.sgml
--- b/doc/src/sgml/config.sgml
*************** include_dir 'conf.d'
*** 1876,1895 ****
          </para>
  
          <para>
!          A good starting point for this setting is the number of separate
           drives comprising a RAID 0 stripe or RAID 1 mirror being used for the
           database.  (For RAID 5 the parity drive should not be counted.)
           However, if the database is often busy with multiple queries issued in
           concurrent sessions, lower values may be sufficient to keep the disk
           array busy.  A value higher than needed to keep the disks busy will
           only result in extra CPU overhead.
!         </para>
! 
!         <para>
!          For more exotic systems, such as memory-based storage or a RAID array
!          that is limited by bus bandwidth, the correct value might be the
!          number of I/O paths available.  Some experimentation may be needed
!          to find the best value.
          </para>
  
          <para>
--- 1876,1891 ----
          </para>
  
          <para>
!          For magnetic drives, a good starting point for this setting is the
!          number of separate
           drives comprising a RAID 0 stripe or RAID 1 mirror being used for the
           database.  (For RAID 5 the parity drive should not be counted.)
           However, if the database is often busy with multiple queries issued in
           concurrent sessions, lower values may be sufficient to keep the disk
           array busy.  A value higher than needed to keep the disks busy will
           only result in extra CPU overhead.
!          SSDs and other memory-based storage can often process many
!          concurrent requests, so the best value might be in the hundreds.
          </para>
  
          <para>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 28 Jun 2016 16:09:23 -0400

> to more accurately cover SSDs.

Patch applied.

+ As you are, so once was I. As I am, so you will be. +
+                     Ancient Roman grave inscription +