Subject: No reference to postgres_fdw in FTS docs

From: [email-masked]
Date: Tue, 31 Oct 2017 10:50:39 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/textsearch-indexes.html
Description:

https://www.postgresql.org/docs/current/static/textsearch-indexes.html

The last paragraph mentions the dblink module, but surely postgres_fdw
deserves a mention here too - especially with its increasing ability to push
more of the query onto the foreign servers.

Also, I think it would be worth mentioning elsewhere in the documentation
(e.g. https://www.postgresql.org/docs/10/static/indexes-types.html) the
impact that maintenance_work_mem has on the creation time for different
index types - currently I can&#39;t find this anywhere else except on this FTS
page.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 12 Jan 2018 16:53:47 -0500

> index types - currently I can&#39;t find this anywhere else except on this FTS

I have applied the attached doc patch which will appear in PG 11. 
Thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +
diff --git a/doc/src/sgml/textsearch.sgml b/doc/src/sgml/textsearch.sgml
new file mode 100644
index 4dc52ec..1a2f040
*** a/doc/src/sgml/textsearch.sgml
--- b/doc/src/sgml/textsearch.sgml
*************** SELECT plainto_tsquery('supernovae stars
*** 3614,3621 ****
     allows the implementation of very fast searches with online update.
     Partitioning can be done at the database level using table inheritance,
     or by distributing documents over
!    servers and collecting search results using the <xref linkend="dblink"/>
!    module. The latter is possible because ranking functions use
     only local information.
    </para>
  
--- 3614,3622 ----
     allows the implementation of very fast searches with online update.
     Partitioning can be done at the database level using table inheritance,
     or by distributing documents over
!    servers and collecting external search results, e.g. via <link
!    linkend="ddl-foreign-data">Foreign Data</link> access.
!    The latter is possible because ranking functions use
     only local information.
    </para>