Subject: Addition to / Clarification in 9.7.1. LIKE

From: [email-masked]
Date: Thu, 14 Dec 2017 09:33:39 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/functions-matching.html
Description:

Between the 1st and 2nd paragraphs please add a new one which make clear
(also to a newbie like myself) that the _only characters_ can be used in
pattern are (_) and (%).

Tia

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 25 Jan 2018 17:55:23 -0500

> (also to a newbie like myself) that the _only characters_ can be used in

Uh, it is not totally clear what you are suggesting here.  I think you
are talking about the LIKE command and its use of _ and %.  What detail
should be added?  Can you show an example?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +

---

From: GPT <[email-masked]>
Date: Fri, 26 Jan 2018 09:52:07 +0100

Between 1st (The LIKE expression...) and 2nd (If pattern does not...)
paragraphs, it could be added something like:

<begin>
                                               Caution
Contrary to some other databases, in Postgresql only two characters
are used in LIKE patterns: underscore (_) and percent sign (%).
The use of any other character will lead to an error.
<end>

The error message also would be more clarified to inform user about
the use of not supported characters.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 26 Jan 2018 08:22:13 -0500

> the use of not supported characters.

Uh, I still don't understand what error you are talking about.  Here are
some examples:

	SELECT 'abc' LIKE 'a_c';
	 ?column?
	----------
	 t
	
	SELECT 'abc' LIKE 'a%c';
	 ?column?
	----------
	 t
	
	SELECT 'abc' LIKE 'a%*c';
	 ?column?
	----------
	 f

Can you show me an example?