Subject: pgrowlocks columns do not match docs: "modes" instead of "lock_type"

From: PG Doc comments form <[email-masked]>
Date: Mon, 01 Oct 2018 09:42:08 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/pgrowlocks.html
Description:

Hi,

The description of the pgrowlocks extension says that the function returns a
column called "lock_type". However this column is really called "modes", as
shown in contrib/pgrowlocks/pgrowlocks--1.2.sql:

CREATE FUNCTION pgrowlocks(IN relname text,
    OUT locked_row TID,     -- row TID
    OUT locker XID,     -- locking XID
    OUT multi bool,     -- multi XID?
    OUT xids xid[],     -- multi XIDs
    OUT modes text[],       -- multi XID statuses
    OUT pids INTEGER[])     -- locker's process id
RETURNS SETOF record
AS 'MODULE_PATHNAME', 'pgrowlocks'
LANGUAGE C STRICT PARALLEL SAFE;

Thanks, Chris.

---

From: Michael Paquier <[email-masked]>
Date: Tue, 2 Oct 2018 16:41:52 +0900

> LANGUAGE C STRICT PARALLEL SAFE;

0ac5ad5 has updated pgrowlocks from 1.0 to 1.1 and it forgot the
documentation.  The order of the columns is correct, but the example was
not.  So I updated the documentation with a fresh one, and fixed it all
the way down to 9.3.  Thanks for the report, Chris!
--
Michael