Subject: Correction For PostgreSQL Manual

From: PG Doc comments form <[email-masked]>
Date: Fri, 25 Oct 2019 21:56:47 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/12/bgworker.html
Description:

The warning about background worker processes at the beginning of Chapter 47
reads:

Administrators wishing to enable modules that include background worker
process ...

Should be:

Administrators wishing to enable modules that include background worker
processes ...

Hope this helps!

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 5 Nov 2019 20:54:46 -0500

> Administrators wishing to enable modules that include background worker

Yes, it does help.  I have fixed it in all supported versions, patch
attached.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +
diff --git a/doc/src/sgml/bgworker.sgml b/doc/src/sgml/bgworker.sgml
index bc5a52584b..ad17b42c89 100644
--- a/doc/src/sgml/bgworker.sgml
+++ b/doc/src/sgml/bgworker.sgml
@@ -23,7 +23,7 @@
    There are considerable robustness and security risks in using background
    worker processes because, being written in the <literal>C</literal> language,
    they have unrestricted access to data.  Administrators wishing to enable
-   modules that include background worker process should exercise extreme
+   modules that include background worker processes should exercise extreme
    caution.  Only carefully audited modules should be permitted to run
    background worker processes.
   </para>

---

From: Justin Pryzby <[email-masked]>
Date: Tue, 5 Nov 2019 20:23:53 -0600

On Tue, Nov 05, 2019 at 08:54:46PM -0500, Bruce Momjian wrote:
> > Administrators wishing to enable modules that include background worker process ...
> > Should be:
> > Administrators wishing to enable modules that include background worker processes ...
> 

It looks like that introduced a different typo in v11 and v12.

git fetch:
da5cd7a..00ac1ec  REL9_4_STABLE -> origin/REL9_4_STABLE 00ac1eced6204656ae393a719063fbef99a2cf4b => ok
74d32ee..5c9b0cd  REL9_5_STABLE -> origin/REL9_5_STABLE 5c9b0cdc52e3ada22fa30cf8c4fcd78fdad29ea7 => ok
648f178..1673a66  REL9_6_STABLE -> origin/REL9_6_STABLE 1673a667d4323f056e4cef715cf4c162190ce8e0 => ok
f5efc93..cb573bd  REL_10_STABLE -> origin/REL_10_STABLE cb573bdde9563aed99aa20b54ec70acc82fac3c5 => ok
8f8ff09..0d8bc87  REL_11_STABLE -> origin/REL_11_STABLE 0d8bc874cfed23e4b59c67221a6564dcdefd3efb => bad: processs
4d04031..f71a299  REL_12_STABLE -> origin/REL_12_STABLE f71a299c6cb87ac17b51ee1b9e389ae5a31b86fa => bad: processs
2a4d96e..a386942  master     -> origin/master           4b5e58b86e3b09daa7384dbbd0bb4cacbd9bd7c6 => ok

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 5 Nov 2019 21:29:18 -0500

> 2a4d96e..a386942  master     -> origin/master           4b5e58b86e3b09daa7384dbbd0bb4cacbd9bd7c6 => ok

Thank you so much for the correction, fixed.