Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1WXiZ5-0000ud-58 for pgsql-hackers@arkaria.postgresql.org; Wed, 09 Apr 2014 02:48:39 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.80) (envelope-from ) id 1WXiZ4-0003Kw-Lx for pgsql-hackers@arkaria.postgresql.org; Wed, 09 Apr 2014 02:48:38 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1WXiZ3-0003Ko-P2 for pgsql-hackers@postgresql.org; Wed, 09 Apr 2014 02:48:37 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtp (Exim 4.80) (envelope-from ) id 1WXiZ1-0005r9-4V for pgsql-hackers@postgresql.org; Wed, 09 Apr 2014 02:48:37 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id s392mWHn002743; Tue, 8 Apr 2014 22:48:32 -0400 From: Tom Lane To: Andrew Dunstan cc: Peter Geoghegan , pgsql-hackers@postgresql.org Subject: Re: default opclass for jsonb (was Re: Call for GIST/GIN/SP-GIST opclass documentation) In-reply-to: <534475B7.6020908@dunslane.net> References: <27299.1396989666@sss.pgh.pa.us> <28589.1396992841@sss.pgh.pa.us> <29030.1396993582@sss.pgh.pa.us> <534475B7.6020908@dunslane.net> Comments: In-reply-to Andrew Dunstan message dated "Tue, 08 Apr 2014 18:18:31 -0400" Date: Tue, 08 Apr 2014 22:48:32 -0400 Message-ID: <2742.1397011712@sss.pgh.pa.us> X-Pg-Spam-Score: -2.2 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org Andrew Dunstan writes: > On 04/08/2014 05:57 PM, Peter Geoghegan wrote: >> ... I didn't propose changing the default due to >> concerns about the POLA, but I'm happy to be told that those concerns >> were out of proportion to the practical benefits of a different >> default. > I tend to agree with Tom that POLA will be more violated by the default > ops class not being able to index some values. We should wait a bit longer to see if anyone objects, but assuming that this represents the consensus opinion ... ISTM that the name "jsonb_ops" should have pride of place as the default jsonb opclass. Therefore, if we make this change, jsonb_hash_ops needs to be renamed to jsonb_ops, and we need a new name for what is now jsonb_ops. I haven't paid attention to the technical details of the differences so I have no idea what to suggest for the new name. Thoughts? regards, tom lane -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers