Subject: documention wrong or just not clear?

From: Robert Treat <[email-masked]>
Date: Thu, 22 Mar 2007 17:15:20 -0400

In http://www.postgresql.org/docs/8.2/static/routine-vacuuming.html it says:

"The age column measures the number of transactions from the cutoff XID to the 
current transaction's XID. Immediately after a VACUUM, age(relfrozenxid) 
should be a little more than the vacuum_freeze_min_age setting that was used 
(more by the number of transactions started since the VACUUM started). "

However my results don't seem to bear that out:

postgres=# show vacuum_freeze_min_age;
vacuum_freeze_min_age
-----------------------
100000000
(1 row)
postgres=# VACUUM ;
VACUUM
postgres=# select min (age(relfrozenxid)) from pg_class where relkind = 'r';
min
--------
253045
(1 row)

-- 
Robert Treat
Build A Brighter LAMP :: Linux Apache {middleware} PostgreSQL

---

From: Tom Lane <[email-masked]>
Date: Thu, 22 Mar 2007 17:29:08 -0400

> However my results don't seem to bear that out:

I would imagine that your database (or at least some of your tables) are
not yet vacuum_freeze_min_age transactions old.

			regards, tom lane