Subject: Minor doc correction for SPI_execute_with_args

From: Ian Barwick <[email-masked]>
Date: Fri, 29 May 2015 17:01:01 +0900

Hi

The documentation for SPI_execute_with_args:

  http://www.postgresql.org/docs/current/static/spi-spi-execute-with-args.html

claims it returns the same value as SPI_execute, whereas it actually
calls SPI_execute_plan which can produce two additional error codes.

Regards

Ian Barwick

-- 
 Ian Barwick                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services
diff --git a/doc/src/sgml/spi.sgml b/doc/src/sgml/spi.sgml
new file mode 100644
index c099fcf..108e160
*** a/doc/src/sgml/spi.sgml
--- b/doc/src/sgml/spi.sgml
*************** int SPI_execute_with_args(const char *<p
*** 842,848 ****
    <title>Return Value</title>
  
    <para>
!    The return value is the same as for <function>SPI_execute</function>.
    </para>
  
    <para>
--- 842,848 ----
    <title>Return Value</title>
  
    <para>
!    The return value is the same as for <function>SPI_execute_plan</function>.
    </para>
  
    <para>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Tom Lane <[email-masked]>
Date: Sat, 30 May 2015 13:57:29 -0400

> calls SPI_execute_plan which can produce two additional error codes.

But SPI_execute also calls _SPI_execute_plan.  Moreover, the documented
reasons for SPI_execute_plan to return additional error codes don't match
up too closely with SPI_execute_with_args (eg, there's no "plan"
argument, so saying "plan was prepared with some parameters" is pretty
meaningless here).

If what you're looking at is the extra error conditions right at the start
of SPI_execute_with_args, my inclination would be to document them without
any reference to SPI_execute_plan, ie we'd add text much like what's
under SPI_execute_plan but with the descriptions of the error codes
adjusted to agree with this function.

			regards, tom lane