Subject: SQL formatting in docs

From: David Niergarth <[email-masked]>
Date: Sun, 05 Apr 2009 13:34:51 -0500

Hopefully not a naive question... How are all the queries in the 
postgres docs formatted? They're all very consistent and nice pretty 
printed, especially complex queries. How can I do the same?

--David

---

From: David Niergarth <[email-masked]>
Date: Sun, 05 Apr 2009 15:20:24 -0500

> printed, especially complex queries. How can I do the same?

As an non-trivial example of what I mean, here's a query from Chapter 
36: The Rule System. Is there an automated way to format/prettyprint 
queries like this?

SELECT shoe_ready.shoename, shoe_ready.sh_avail,
        shoe_ready.sl_name, shoe_ready.sl_avail,
        shoe_ready.total_avail
   FROM (SELECT rsh.shoename,
                rsh.sh_avail,
                rsl.sl_name,
                rsl.sl_avail,
                min(rsh.sh_avail, rsl.sl_avail) AS total_avail
           FROM (SELECT sh.shoename,
                        sh.sh_avail,
                        sh.slcolor,
                        sh.slminlen,
                        sh.slminlen * un.un_fact AS slminlen_cm,
                        sh.slmaxlen,
                        sh.slmaxlen * un.un_fact AS slmaxlen_cm,
                        sh.slunit
                   FROM shoe_data sh, unit un
                  WHERE sh.slunit = un.un_name) rsh,
                (SELECT s.sl_name,
                        s.sl_avail,
                        s.sl_color,
                        s.sl_len,
                        s.sl_unit,
                        s.sl_len * u.un_fact AS sl_len_cm
                   FROM shoelace_data s, unit u
                  WHERE s.sl_unit = u.un_name) rsl
          WHERE rsl.sl_color = rsh.slcolor
            AND rsl.sl_len_cm >= rsh.slminlen_cm
            AND rsl.sl_len_cm <= rsh.slmaxlen_cm) shoe_ready
  WHERE shoe_ready.total_avail > 2;

Thanks,

--David

---

From: Tom Lane <[email-masked]>
Date: Sun, 05 Apr 2009 16:37:28 -0400

> printed, especially complex queries. How can I do the same?

I'm afraid they're all laid out by hand :-(

			regards, tom lane

---

From: David Niergarth <[email-masked]>
Date: Sun, 05 Apr 2009 15:41:17 -0500

Thanks for settling that for me; I've always wondered about it!

--David