Subject: Punctuation error

From: PG Doc comments form <[email-masked]>
Date: Tue, 18 Sep 2018 22:56:10 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/logical-replication-publication.html
Description:

This sentence should not use a semicolon: "Both the ADD TABLE and DROP TABLE
operations are transactional; so the table will start or stop replicating at
the correct snapshot once the transaction has committed." You can either
change it to a comma, or else leave out the "so" that follows the semicolon.
The text that follows a semicolon must be a complete sentence that stands on
its own.

---

From: Tom Lane <[email-masked]>
Date: Wed, 19 Sep 2018 10:43:25 -0400

=?utf-8?q?PG_Doc_comments_form?= <[email-masked]> writes:
> the correct snapshot once the transaction has committed."

That looks perfectly fine to me.  Moreover, there are a *lot* of places
in the PG docs that we'd have to change if we got persnickety about this
sort of thing.

> You can either

I am unfamiliar with this grammar "rule", and vigorously dispute that
anyone follows it in the real world.

			regards, tom lane

---

From: Neil <[email-masked]>
Date: Wed, 19 Sep 2018 10:23:41 -0500

> On Sep 19, 2018, at 9:43 AM, Tom Lane <[email-masked]> wrote:
> 

Seems Tom is correct for at least the last 100 years or so.  From Strunk & White, Elements of Style 1918, Rule 5 (available on-line). Not saying this is the definitive PG writing guide, but most of us in the US used it for college writing.

“Note that if the second clause is preceded by an adverb, such as accordingly, besides, so, then, therefore, or thus, and not by a conjunction, the semicolon is still required.”

“I had never been in the place before; so I had difficulty in finding my way about.”

Neil