Subject: patch for overflowing tables

From: Brian Gough <[email-masked]>
Date: Tue, 17 Apr 2007 17:29:59 +0100

Hello,

The cols attribute in a couple of tables does not match
the actual number of entries in the tables, causing
them to overflow the edge of the page.  The patch below
fixes the problem -- I didn't find any other cases
apart from these two.

-- 
best regards,

Brian Gough

Index: doc/src/sgml/datatype.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/datatype.sgml,v
retrieving revision 1.195
diff -u -8 -r1.195 datatype.sgml
--- doc/src/sgml/datatype.sgml	6 Apr 2007 19:22:38 -0000	1.195
+++ doc/src/sgml/datatype.sgml	17 Apr 2007 16:02:04 -0000
@@ -1933,17 +1933,17 @@
       (In particular, <literal>now</> and related strings are converted
       to a specific time value as soon as they are read.)
       All of these values need to be written in single quotes when used
       as constants in SQL commands.
      </para>
 
       <table id="datatype-datetime-special-table">
        <title>Special Date/Time Inputs</title>
-       <tgroup cols="2">
+       <tgroup cols="3">
         <thead>
          <row>
           <entry>Input String</entry>
           <entry>Valid Types</entry>
           <entry>Description</entry>
          </row>
         </thead>
         <tbody>
Index: doc/src/sgml/ecpg.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/ecpg.sgml,v
retrieving revision 1.82
diff -u -8 -r1.82 ecpg.sgml
--- doc/src/sgml/ecpg.sgml	16 Feb 2007 03:56:45 -0000	1.82
+++ doc/src/sgml/ecpg.sgml	17 Apr 2007 16:02:07 -0000
@@ -1480,17 +1480,17 @@
         the month and <literal>dd</literal> to indicate the position of the
         day.
        </para>
        <para>
         The following table indicates a few possible formats. This will give
         you an idea of how to use this function.
         <table>
          <title>Valid input formats for <function>rdefmtdate</function></title>
-         <tgroup cols="2">
+         <tgroup cols="3">
           <thead>
            <row>
             <entry>fmt</entry>
             <entry>str</entry>
             <entry>result</entry>
            </row>
           </thead>
           <tbody>

---

From: Tom Lane <[email-masked]>
Date: Tue, 17 Apr 2007 13:31:27 -0400

> fixes the problem -- I didn't find any other cases

Good catch --- applied.

			regards, tom lane