Subject: Earliest Postgres credit patch

From: Ross Reedstrom <[email-masked]>
Date: Wed, 5 Aug 2015 13:17:38 -0500

In reponse to Bruce's call for action on his blog, I spent my lunch hour doing
a bit of transcription. Attached patch transcribes the list of Berkely students
and staff who help write Postgres from Dr. Stonebraker's Turing Lecture:

https://www.youtube.com/watch?v=BbGeKi6T6QI&feature=youtu.be&t=1h11m09s

Ross
-- 
Ross Reedstrom, Ph.D.                                 [email-masked]
Systems Engineer & Admin, Research Scientist        phone: 713-348-6166
Connexions                  http://cnx.org            fax: 713-348-3665
Rice University MS-375, Houston, TX 77005
GPG Key fingerprint = F023 82C8 9B0E 2CC6 0D8E  F888 D3AE 810E 88F0 BEDE
diff --git a/doc/src/sgml/release-old.sgml b/doc/src/sgml/release-old.sgml
index ec8e43f..07d5f57 100644
--- a/doc/src/sgml/release-old.sgml
+++ b/doc/src/sgml/release-old.sgml
@@ -6554,6 +6554,30 @@ The following bugs have been fixed in postgres95-beta-0.02:
 <para>
 Initial release.
 </para>
+
+<para>
+As reported by Dr. Michael Stonebraker, in his June 13, 2015 2014 ACM A.M. Turing Lecture:
+<programlisting>
+The Following 39 Berkeley Students and Staff 
+               Wrote Postgres
+(under the direction of Larry Rowe and myself)
+
+Jeff Alton, Paul Aoki, James Bell, Jennifer Caetta,
+Philip Chang, Jolly Chen, Ron Choi, Matt Dillon,
+Zelaine Fong, Adam Glass, Jeffrey Goh, Steven Grady,
+Serge Granik, Marti Hearst, Joey Hellerstein,
+Michael Hirohama, Chin-heng Hong, Wei Hong,
+Anant Jhingren, Greg Kemnitz, Marcel Kornacker,
+Case Larsen, Boris Livshitz, Jeff Meredith, Ginger Ogle,
+Mike Olson, Nels Olson, Lay-Peng Ong, Carol Paxson,
+Avi Pfeffer, Spyros Potamianos, Sunita Surawagi,
+David Muir Sharnoff, Mark Sullivan, Cimarron Taylor,
+Marc Teitelbaum, Yongdong Wang, Kristen Wright, and
+Andrew Yu
+</programlisting>
+Transcribed from <ulink url="https://www.youtube.com/watch?v=BbGeKi6T6QI&amp;feature=youtu.be&amp;t=1h11m09s"></ulink>
+accessed on August 5, 2015 
+</para>
 </sect1>
 
 <![IGNORE[

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: er <[email-masked]>
Date: Wed, 05 Aug 2015 20:45:16 +0200

> https://www.youtube.com/watch?v=BbGeKi6T6QI&feature=youtu.be&t=1h11m09s

(tentative, google-based) emendations:

s/Chin-heng/Chin-Heng/
s/Jhingren/Jhingran/
s/Boris Livshitz/Boris Livshutz/

Also, those consecutive years: '2015 2014' on the first line are rather 
hard to read; a paraphrase would be good.

Thanks,

Erik Rijkers

---

From: Ross Reedstrom <[email-masked]>
Date: Wed, 5 Aug 2015 14:09:02 -0500

> s/Boris Livshitz/Boris Livshutz/

Hmm, the problem here, is that the patch is an accurate transcription of a
slide in the talk (seen at the timepoint at that URL - no need to scrub at all)

 should either add ibid. or edit brackets, or ...?

The first is a case difference/alternate transcription. Stonebraker's list of
publications does support the first two changes.

The last, in particular, is wrong: I find 1993 vintage email threads (on GRASS)
w/ a sigblock:

-Boris Livshitz
 Postgres Group
 UC-Berkeley, Computer Science

> 
> Also, those consecutive years: '2015 2014' on the first line are
> rather hard to read; a paraphrase would be good.

Yeah, probably:

As reported by Dr. Michael Stonebraker, 2014 ACM A.M. Turing Lecture,
delivered June 13, 2015 (amended):

Amended attached.

Ross

-- 
Ross Reedstrom, Ph.D.                                 [email-masked]
Systems Engineer & Admin, Research Scientist        phone: 713-348-6166
Connexions                  http://cnx.org            fax: 713-348-3665
Rice University MS-375, Houston, TX 77005
GPG Key fingerprint = F023 82C8 9B0E 2CC6 0D8E  F888 D3AE 810E 88F0 BEDE
diff --git a/doc/src/sgml/release-old.sgml b/doc/src/sgml/release-old.sgml
index ec8e43f..db87e93 100644
--- a/doc/src/sgml/release-old.sgml
+++ b/doc/src/sgml/release-old.sgml
@@ -6554,6 +6554,31 @@ The following bugs have been fixed in postgres95-beta-0.02:
 <para>
 Initial release.
 </para>
+
+<para>
+As reported by Dr. Michael Stonebraker, in his ACM A.M. Turing Lecture,
+delivered on  June 13, 2015 2014 (amended):
+<programlisting>
+The Following 39 Berkeley Students and Staff 
+               Wrote Postgres
+(under the direction of Larry Rowe and myself)
+
+Jeff Alton, Paul Aoki, James Bell, Jennifer Caetta,
+Philip Chang, Jolly Chen, Ron Choi, Matt Dillon,
+Zelaine Fong, Adam Glass, Jeffrey Goh, Steven Grady,
+Serge Granik, Marti Hearst, Joey Hellerstein,
+Michael Hirohama, Chin-Heng Hong, Wei Hong,
+Anant Jhingran, Greg Kemnitz, Marcel Kornacker,
+Case Larsen, Boris Livshitz, Jeff Meredith, Ginger Ogle,
+Mike Olson, Nels Olson, Lay-Peng Ong, Carol Paxson,
+Avi Pfeffer, Spyros Potamianos, Sunita Surawagi,
+David Muir Sharnoff, Mark Sullivan, Cimarron Taylor,
+Marc Teitelbaum, Yongdong Wang, Kristen Wright, and
+Andrew Yu
+</programlisting>
+Transcribed from <ulink url="https://www.youtube.com/watch?v=BbGeKi6T6QI&amp;feature=youtu.be&amp;t=1h11m09s"></ulink>
+accessed on August 5, 2015 
+</para>
 </sect1>
 
 <![IGNORE[

---

From: Erik Rijkers <[email-masked]>
Date: Wed, 05 Aug 2015 21:20:19 +0200

>  UC-Berkeley, Computer Science

Oh ok, I had forgotten the text was up there in the video.

Fair enough.  Then again, I found this:

https://www.linkedin.com/in/livshutz

Seems to be the same person.

I guess it doesn't matter too much.

Thanks,

Erik Rijkers

---

From: Ross Reedstrom <[email-masked]>
Date: Fri, 7 Aug 2015 12:15:57 -0500

*sigh* I editted correctly in the message, but screwed up
the moving the test with the dates in the actual patch. Here's
a better one.

Ross

index ec8e43f..ce05b35 100644
+As reported by Dr. Michael Stonebraker, in his 2014 ACM A.M. Turing Lecture,
+delivered on  June 13, 2015 (amended):
 
 <![IGNORE[