Subject: Links for upgraders

From: Vik Fearing <[email-masked]>
Date: Mon, 20 Jan 2014 07:50:22 +0100

The attached patch aims to help upgraders find the relevant information
important to their upgrade.

I would have liked to link the version number instead of adding more
text, but I didn't find a way to do that.

This patch was generated with the following command:

doc$ find . -type f -print0 | xargs -0 sed -i -e "s/release notes for
\([0-9]\+\)\.\([0-9]\+\)\.\([0-9]\+\)/release note for \1.\2.\3 in <xref
linkend=\"release-\1-\2-\3\">/g"

-- 
Vik

*** a/doc/src/sgml/release-7.4.sgml
--- b/doc/src/sgml/release-7.4.sgml
***************
*** 27,33 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release notes for 7.4.26.
     </para>
  
    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release note for 7.4.26 in <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 161,167 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release notes for 7.4.26.
     </para>
  
    </sect2>
--- 161,167 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release note for 7.4.26 in <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 305,311 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release notes for 7.4.26.
     </para>
  
    </sect2>
--- 305,311 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release note for 7.4.26 in <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 418,424 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release notes for 7.4.26.
     </para>
  
    </sect2>
--- 418,424 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see the release note for 7.4.26 in <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 540,546 ****
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 7.4.26.
      Also, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 540,546 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 7.4.26.
      Also, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 668,674 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 668,674 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 748,754 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 748,754 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 834,840 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 834,840 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 918,924 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 918,924 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 994,1000 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 994,1000 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1048,1054 ****
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release notes for 7.4.11.
     </para>
  
    </sect2>
--- 1048,1054 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see the release note for 7.4.11 in <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-8.0.sgml
--- b/doc/src/sgml/release-8.0.sgml
***************
*** 27,33 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release notes for 8.0.22.
     </para>
  
    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release note for 8.0.22 in <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 231,237 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release notes for 8.0.22.
     </para>
  
    </sect2>
--- 231,237 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release note for 8.0.22 in <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 391,397 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release notes for 8.0.22.
     </para>
  
    </sect2>
--- 391,397 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release note for 8.0.22 in <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 562,568 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release notes for 8.0.22.
     </para>
  
    </sect2>
--- 562,568 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see the release note for 8.0.22 in <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 719,725 ****
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.0.22.
      Also, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 719,725 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.0.22.
      Also, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 881,887 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 881,887 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 961,967 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 961,967 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1047,1053 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 1047,1053 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1158,1164 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 1158,1164 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1292,1298 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 1292,1298 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1346,1352 ****
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release notes for 8.0.6.
     </para>
  
    </sect2>
--- 1346,1352 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see the release note for 8.0.6 in <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-8.1.sgml
--- b/doc/src/sgml/release-8.1.sgml
***************
*** 27,33 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release notes for 8.1.18.
     </para>
  
    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release note for 8.1.18 in <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 246,252 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release notes for 8.1.18.
     </para>
  
    </sect2>
--- 246,252 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release note for 8.1.18 in <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 458,464 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release notes for 8.1.18.
     </para>
  
    </sect2>
--- 458,464 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release note for 8.1.18 in <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 612,618 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release notes for 8.1.18.
     </para>
  
    </sect2>
--- 612,618 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release note for 8.1.18 in <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 802,808 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release notes for 8.1.18.
     </para>
  
    </sect2>
--- 802,808 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see the release note for 8.1.18 in <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 985,991 ****
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.1.18.
      Also, if you are upgrading from a version earlier than 8.1.15,
!     see the release notes for 8.1.15.
     </para>
  
    </sect2>
--- 985,991 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.1.18.
      Also, if you are upgrading from a version earlier than 8.1.15,
!     see the release note for 8.1.15 in <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1147,1153 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see the release notes for 8.1.15.
     </para>
  
    </sect2>
--- 1147,1153 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see the release note for 8.1.15 in <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1270,1276 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see the release notes for 8.1.15.
     </para>
  
    </sect2>
--- 1270,1276 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see the release note for 8.1.15 in <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1390,1396 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.  Also, if you were running a previous
      8.1.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
--- 1390,1396 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.  Also, if you were running a previous
      8.1.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
***************
*** 1542,1548 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 1542,1548 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 1718,1724 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 1718,1724 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 1785,1791 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 1785,1791 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2045,2051 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2045,2051 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2287,2293 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2287,2293 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2409,2415 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2409,2415 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2499,2505 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2499,2505 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2542,2548 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2542,2548 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2643,2649 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2643,2649 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2793,2799 ****
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
    </sect2>
--- 2793,2799 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2871,2877 **** compilers (Hiroshi Saito)</para></listitem>
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
  
     <para>
--- 2871,2877 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
  
     <para>
***************
*** 3025,3031 **** documented (Tom)</para></listitem>
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release notes for 8.1.2.
     </para>
    </sect2>
  
--- 3025,3031 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see the release note for 8.1.2 in <xref linkend="release-8-1-2">.
     </para>
    </sect2>
  
*** a/doc/src/sgml/release-8.2.sgml
--- b/doc/src/sgml/release-8.2.sgml
***************
*** 37,43 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 37,43 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 255,261 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 255,261 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 556,562 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 556,562 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 688,694 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 688,694 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 820,826 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 820,826 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1064,1070 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 1064,1070 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1350,1356 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 1350,1356 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1551,1557 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 1551,1557 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1822,1828 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release notes for 8.2.14.
     </para>
  
    </sect2>
--- 1822,1828 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see the release note for 8.2.14 in <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 2068,2074 ****
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.2.14.
      Also, if you are upgrading from a version earlier than 8.2.11,
!     see the release notes for 8.2.11.
     </para>
  
    </sect2>
--- 2068,2074 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.2.14.
      Also, if you are upgrading from a version earlier than 8.2.11,
!     see the release note for 8.2.11 in <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2296,2302 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see the release notes for 8.2.11.
     </para>
  
    </sect2>
--- 2296,2302 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see the release note for 8.2.11 in <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2462,2468 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see the release notes for 8.2.11.
     </para>
  
    </sect2>
--- 2462,2468 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see the release note for 8.2.11 in <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2641,2647 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.  Also, if you were running a previous
      8.2.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
--- 2641,2647 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release note for 8.2.7 in <xref linkend="release-8-2-7">.  Also, if you were running a previous
      8.2.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
***************
*** 2825,2831 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.
     </para>
  
    </sect2>
--- 2825,2831 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release note for 8.2.7 in <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
***************
*** 3057,3063 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.
     </para>
  
    </sect2>
--- 3057,3063 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release note for 8.2.7 in <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
***************
*** 3124,3130 ****
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release notes for 8.2.7.
     </para>
  
    </sect2>
--- 3124,3130 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see the release note for 8.2.7 in <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-8.3.sgml
--- b/doc/src/sgml/release-8.3.sgml
***************
*** 30,36 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 199,205 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 199,205 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 495,501 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 495,501 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 605,611 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 605,611 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 822,828 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 822,828 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 1051,1057 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release notes for 8.3.17.
     </para>
  
    </sect2>
--- 1051,1057 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see the release note for 8.3.17 in <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 1346,1352 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 1346,1352 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 1603,1609 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 1603,1609 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 1974,1980 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 1974,1980 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2137,2143 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 2137,2143 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2269,2275 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 2269,2275 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2547,2553 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 2547,2553 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2910,2916 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 2910,2916 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3139,3145 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 3139,3145 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3466,3472 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release notes for 8.3.8.
     </para>
  
    </sect2>
--- 3466,3472 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see the release note for 8.3.8 in <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3801,3807 ****
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.3.8.
      Also, if you are upgrading from a version earlier than 8.3.5,
!     see the release notes for 8.3.5.
     </para>
  
    </sect2>
--- 3801,3807 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.3.8.
      Also, if you are upgrading from a version earlier than 8.3.5,
!     see the release note for 8.3.5 in <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4089,4095 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see the release notes for 8.3.5.
     </para>
  
    </sect2>
--- 4089,4095 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see the release note for 8.3.5 in <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4312,4318 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see the release notes for 8.3.5.
     </para>
  
    </sect2>
--- 4312,4318 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see the release note for 8.3.5 in <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4606,4612 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.  Also, if you were running a previous
      8.3.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
--- 4606,4612 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release note for 8.3.1 in <xref linkend="release-8-3-1">.  Also, if you were running a previous
      8.3.X release, it is recommended to <command>REINDEX</> all GiST
      indexes after the upgrade.
     </para>
***************
*** 4861,4867 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.
     </para>
  
    </sect2>
--- 4861,4867 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release note for 8.3.1 in <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
***************
*** 5215,5221 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.
     </para>
  
    </sect2>
--- 5215,5221 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release note for 8.3.1 in <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
***************
*** 5282,5288 ****
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release notes for 8.3.1.
     </para>
  
    </sect2>
--- 5282,5288 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see the release note for 8.3.1 in <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-8.4.sgml
--- b/doc/src/sgml/release-8.4.sgml
***************
*** 30,36 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.17,
!     see the release notes for 8.4.17.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.17,
!     see the release note for 8.4.17 in <xref linkend="release-8-4-17">.
     </para>
  
    </sect2>
***************
*** 225,231 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.17,
!     see the release notes for 8.4.17.
     </para>
  
    </sect2>
--- 225,231 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.17,
!     see the release note for 8.4.17 in <xref linkend="release-8-4-17">.
     </para>
  
    </sect2>
***************
*** 432,438 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 432,438 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 654,660 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 654,660 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 864,870 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 864,870 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1166,1172 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 1166,1172 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1282,1288 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 1282,1288 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1516,1522 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 1516,1522 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1801,1807 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release notes for 8.4.10.
     </para>
  
    </sect2>
--- 1801,1807 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see the release note for 8.4.10 in <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 2170,2176 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.8,
!     see the release notes for 8.4.8.
     </para>
  
    </sect2>
--- 2170,2176 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.8,
!     see the release note for 8.4.8 in <xref linkend="release-8-4-8">.
     </para>
  
    </sect2>
***************
*** 2478,2484 ****
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.8,
!     see the release notes for 8.4.8.
     </para>
  
    </sect2>
--- 2478,2484 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.8,
!     see the release note for 8.4.8 in <xref linkend="release-8-4-8">.
     </para>
  
    </sect2>
***************
*** 3014,3020 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 3014,3020 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3248,3254 ****
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 3248,3254 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3380,3386 ****
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 3380,3386 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3691,3697 ****
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 3691,3697 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 4213,4219 ****
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 4213,4219 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 4504,4510 ****
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release notes for 8.4.2.
     </para>
  
    </sect2>
--- 4504,4510 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see the release note for 8.4.2 in <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-9.0.sgml
--- b/doc/src/sgml/release-9.0.sgml
***************
*** 30,36 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.13,
!     see the release notes for 9.0.13.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.13,
!     see the release note for 9.0.13 in <xref linkend="release-9-0-13">.
     </para>
  
    </sect2>
***************
*** 262,268 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.13,
!     see the release notes for 9.0.13.
     </para>
  
    </sect2>
--- 262,268 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.13,
!     see the release note for 9.0.13 in <xref linkend="release-9-0-13">.
     </para>
  
    </sect2>
***************
*** 535,541 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 535,541 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 825,831 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 825,831 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1087,1093 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 1087,1093 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1465,1471 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 1465,1471 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1607,1613 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 1607,1613 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1913,1919 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 1913,1919 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 2233,2239 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release notes for 9.0.6.
     </para>
  
    </sect2>
--- 2233,2239 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see the release note for 9.0.6 in <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 2756,2762 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.4,
!     see the release notes for 9.0.4.
     </para>
  
    </sect2>
--- 2756,2762 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.4,
!     see the release note for 9.0.4 in <xref linkend="release-9-0-4">.
     </para>
  
    </sect2>
***************
*** 3133,3139 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.4,
!     see the release notes for 9.0.4.
     </para>
  
    </sect2>
--- 3133,3139 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.4,
!     see the release note for 9.0.4 in <xref linkend="release-9-0-4">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-9.1.sgml
--- b/doc/src/sgml/release-9.1.sgml
***************
*** 30,36 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.9,
!     see the release notes for 9.1.9.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.9,
!     see the release note for 9.1.9 in <xref linkend="release-9-1-9">.
     </para>
  
    </sect2>
***************
*** 281,287 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.9,
!     see the release notes for 9.1.9.
     </para>
  
    </sect2>
--- 281,287 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.9,
!     see the release note for 9.1.9 in <xref linkend="release-9-1-9">.
     </para>
  
    </sect2>
***************
*** 623,629 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.6,
!     see the release notes for 9.1.6.
     </para>
  
    </sect2>
--- 623,629 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.6,
!     see the release note for 9.1.6 in <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 950,956 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see the release notes for 9.1.6.
     </para>
  
    </sect2>
--- 950,956 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see the release note for 9.1.6 in <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 1272,1278 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see the release notes for 9.1.6.
     </para>
  
    </sect2>
--- 1272,1278 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see the release note for 9.1.6 in <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 1741,1747 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.4,
!     see the release notes for 9.1.4.
     </para>
  
    </sect2>
--- 1741,1747 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.4,
!     see the release note for 9.1.4 in <xref linkend="release-9-1-4">.
     </para>
  
    </sect2>
***************
*** 1990,1996 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.4,
!     see the release notes for 9.1.4.
     </para>
  
    </sect2>
--- 1990,1996 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.4,
!     see the release note for 9.1.4 in <xref linkend="release-9-1-4">.
     </para>
  
    </sect2>
***************
*** 2389,2395 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.2,
!     see the release notes for 9.1.2.
     </para>
  
    </sect2>
--- 2389,2395 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.2,
!     see the release note for 9.1.2 in <xref linkend="release-9-1-2">.
     </para>
  
    </sect2>
***************
*** 2867,2873 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.2,
!     see the release notes for 9.1.2.
     </para>
  
    </sect2>
--- 2867,2873 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.2,
!     see the release note for 9.1.2 in <xref linkend="release-9-1-2">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-9.2.sgml
--- b/doc/src/sgml/release-9.2.sgml
***************
*** 30,36 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.4,
!     see the release notes for 9.2.4.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.4,
!     see the release note for 9.2.4 in <xref linkend="release-9-2-4">.
     </para>
  
    </sect2>
***************
*** 361,367 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.4,
!     see the release notes for 9.2.4.
     </para>
  
    </sect2>
--- 361,367 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.4,
!     see the release note for 9.2.4 in <xref linkend="release-9-2-4">.
     </para>
  
    </sect2>
***************
*** 780,786 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.2,
!     see the release notes for 9.2.2.
     </para>
  
    </sect2>
--- 780,786 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.2,
!     see the release note for 9.2.2 in <xref linkend="release-9-2-2">.
     </para>
  
    </sect2>
***************
*** 1180,1186 ****
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.2,
!     see the release notes for 9.2.2.
     </para>
  
    </sect2>
--- 1180,1186 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.2,
!     see the release note for 9.2.2 in <xref linkend="release-9-2-2">.
     </para>
  
    </sect2>
***************
*** 1637,1643 ****
  
     <para>
      Also, if you are upgrading from version 9.2.0,
!     see the release notes for 9.2.1.
     </para>
  
    </sect2>
--- 1637,1643 ----
  
     <para>
      Also, if you are upgrading from version 9.2.0,
!     see the release note for 9.2.1 in <xref linkend="release-9-2-1">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-9.3.sgml
--- b/doc/src/sgml/release-9.3.sgml
***************
*** 30,36 ****
  
     <para>
      Also, if you are upgrading from a version earlier than 9.3.1,
!     see the release notes for 9.3.1.
     </para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.3.1,
!     see the release note for 9.3.1 in <xref linkend="release-9-3-1">.
     </para>
  
    </sect2>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Tom Lane <[email-masked]>
Date: Mon, 20 Jan 2014 02:35:50 -0500

> important to their upgrade.

This seems like a good idea, but bad implementation.

Why didn't you follow the existing style for the major-version links?
That is, a pattern like

    However, if you are upgrading from a version earlier than 9.0.6,
    see <xref linkend="release-9-0-6">.

What you've got is not just inconsistent with that nearby usage, but
redundant (especially in the plain-text output format) and bad grammar.

			regards, tom lane

---

From: Vik Fearing <[email-masked]>
Date: Mon, 20 Jan 2014 16:42:58 +0100

> redundant (especially in the plain-text output format) and bad grammar.

I believe to have addressed your concerns in this new patch.  I did not
do "make postgres.txt" on the previous version, but I did do it on this
one and it looks okay to me.

-- 
Vik

    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 161,167 ****
     <para>
  
    </sect2>
--- 161,167 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 305,311 ****
     <para>
  
    </sect2>
--- 305,311 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 418,424 ****
     <para>
  
    </sect2>
--- 418,424 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.26,
!     see <xref linkend="release-7-4-26">.
     </para>
  
    </sect2>
***************
*** 540,546 ****
  
    </sect2>
--- 540,546 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 7.4.26.
      Also, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 668,674 ****
     <para>
  
    </sect2>
--- 668,674 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 748,754 ****
     <para>
  
    </sect2>
--- 748,754 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 834,840 ****
     <para>
  
    </sect2>
--- 834,840 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 918,924 ****
     <para>
  
    </sect2>
--- 918,924 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 994,1000 ****
     <para>
  
    </sect2>
--- 994,1000 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1048,1054 ****
     <para>
  
    </sect2>
--- 1048,1054 ----
     <para>
      A dump/restore is not required for those running 7.4.X.
      However, if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1193,1200 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1193,1200 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1346,1353 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1346,1353 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1423,1430 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1423,1430 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1494,1501 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1494,1501 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1564,1571 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1564,1571 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1653,1660 ****
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
    </sect2>
--- 1653,1660 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
    </sect2>
***************
*** 1701,1708 **** ANYARRAY</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
  
     <para>
--- 1701,1708 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
  
     <para>
***************
*** 1807,1814 **** Fuhr)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11, see the release
!     notes for 7.4.11.
     </para>
    </sect2>
  
--- 1807,1814 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.11,
!     see <xref linkend="release-7-4-11">.
     </para>
    </sect2>
  
***************
*** 1870,1877 **** and <function>isinf</> during configure (Tom)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8, see the release
!     notes for 7.4.8.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
--- 1870,1877 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8,
!     see <xref linkend="release-7-4-8">.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
***************
*** 1937,1944 **** what's actually returned by the query (Joe)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8, see the release
!     notes for 7.4.8.
     </para>
    </sect2>
  
--- 1937,1944 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8,
!     see <xref linkend="release-7-4-8">.
     </para>
    </sect2>
  
***************
*** 1990,1997 **** table has been dropped</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8, see the release
!     notes for 7.4.8.
     </para>
    </sect2>
  
--- 1990,1997 ----
  
     <para>
      A dump/restore is not required for those running 7.4.X.  However,
!     if you are upgrading from a version earlier than 7.4.8,
!     see <xref linkend="release-7-4-8">.
     </para>
    </sect2>

    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 231,237 ****
     <para>
  
    </sect2>
--- 231,237 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 391,397 ****
     <para>
  
    </sect2>
--- 391,397 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 562,568 ****
     <para>
  
    </sect2>
--- 562,568 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.22,
!     see <xref linkend="release-8-0-22">.
     </para>
  
    </sect2>
***************
*** 719,725 ****
  
    </sect2>
--- 719,725 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.0.22.
      Also, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 881,887 ****
     <para>
  
    </sect2>
--- 881,887 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 961,967 ****
     <para>
  
    </sect2>
--- 961,967 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1047,1053 ****
     <para>
  
    </sect2>
--- 1047,1053 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1158,1164 ****
     <para>
  
    </sect2>
--- 1158,1164 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1292,1298 ****
     <para>
  
    </sect2>
--- 1292,1298 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1346,1352 ****
     <para>
  
    </sect2>
--- 1346,1352 ----
     <para>
      A dump/restore is not required for those running 8.0.X.
      However, if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1592,1599 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 1592,1599 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1798,1805 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 1798,1805 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1907,1914 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 1907,1914 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 1983,1990 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 1983,1990 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 2026,2033 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 2026,2033 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 2096,2103 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 2096,2103 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 2215,2222 ****
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
    </sect2>
--- 2215,2222 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
    </sect2>
***************
*** 2272,2279 **** Wieland)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
  
     <para>
--- 2272,2279 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
  
     <para>
***************
*** 2385,2392 **** Fuhr)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6, see the release
!     notes for 8.0.6.
     </para>
    </sect2>
  
--- 2385,2392 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.6,
!     see <xref linkend="release-8-0-6">.
     </para>
    </sect2>
  
***************
*** 2484,2491 **** and <function>isinf</> during configure (Tom)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3, see the release
!     notes for 8.0.3.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
--- 2484,2491 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3,
!     see <xref linkend="release-8-0-3">.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
***************
*** 2569,2576 **** what's actually returned by the query (Joe)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3, see the release
!     notes for 8.0.3.
     </para>
    </sect2>
  
--- 2569,2576 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3,
!     see <xref linkend="release-8-0-3">.
     </para>
    </sect2>
  
***************
*** 2651,2658 **** to subquery results</para></listitem>
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3, see the release
!     notes for 8.0.3.
     </para>
    </sect2>
  
--- 2651,2658 ----
  
     <para>
      A dump/restore is not required for those running 8.0.X.  However,
!     if you are upgrading from a version earlier than 8.0.3,
!     see <xref linkend="release-8-0-3">.
     </para>
    </sect2>

    </sect2>
--- 27,33 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 246,252 ****
     <para>
  
    </sect2>
--- 246,252 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 458,464 ****
     <para>
  
    </sect2>
--- 458,464 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 612,618 ****
     <para>
  
    </sect2>
--- 612,618 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 802,808 ****
     <para>
  
    </sect2>
--- 802,808 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.18,
!     see <xref linkend="release-8-1-18">.
     </para>
  
    </sect2>
***************
*** 985,991 ****
  
    </sect2>
--- 985,991 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.1.18.
      Also, if you are upgrading from a version earlier than 8.1.15,
!     see <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1147,1153 ****
     <para>
  
    </sect2>
--- 1147,1153 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1270,1276 ****
     <para>
  
    </sect2>
--- 1270,1276 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.15,
!     see <xref linkend="release-8-1-15">.
     </para>
  
    </sect2>
***************
*** 1390,1396 ****
     <para>
!     see <xref linkend="release-8-1-2">.  Also, if you were running a previous
  
    </sect2>
--- 1542,1548 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 1718,1724 ****
     <para>
  
    </sect2>
--- 1718,1724 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 1785,1791 ****
     <para>
  
    </sect2>
--- 1785,1791 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2045,2051 ****
     <para>
  
    </sect2>
--- 2045,2051 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2287,2293 ****
     <para>
  
    </sect2>
--- 2287,2293 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2409,2415 ****
     <para>
  
    </sect2>
--- 2409,2415 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2499,2505 ****
     <para>
  
    </sect2>
--- 2499,2505 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2542,2548 ****
     <para>
  
    </sect2>
--- 2542,2548 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2643,2649 ****
     <para>
  
    </sect2>
--- 2643,2649 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
*** 2793,2799 ****
     <para>
  
    </sect2>
--- 2793,2799 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
    </sect2>
***************
  
     <para>
--- 2871,2877 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
  
     <para>
***************
  
--- 3025,3031 ----
     <para>
      A dump/restore is not required for those running 8.1.X.
      However, if you are upgrading from a version earlier than 8.1.2,
!     see <xref linkend="release-8-1-2">.
     </para>
    </sect2>

     <para>
  
    </sect2>
--- 37,43 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 255,261 ****
     <para>
  
    </sect2>
--- 255,261 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 556,562 ****
     <para>
  
    </sect2>
--- 556,562 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 688,694 ****
     <para>
  
    </sect2>
--- 688,694 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 820,826 ****
     <para>
  
    </sect2>
--- 820,826 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1064,1070 ****
     <para>
  
    </sect2>
--- 1064,1070 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1350,1356 ****
     <para>
  
    </sect2>
--- 1350,1356 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1551,1557 ****
     <para>
  
    </sect2>
--- 1551,1557 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 1822,1828 ****
     <para>
  
    </sect2>
--- 1822,1828 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.14,
!     see <xref linkend="release-8-2-14">.
     </para>
  
    </sect2>
***************
*** 2068,2074 ****
  
    </sect2>
--- 2068,2074 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.2.14.
      Also, if you are upgrading from a version earlier than 8.2.11,
!     see <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2296,2302 ****
     <para>
  
    </sect2>
--- 2296,2302 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2462,2468 ****
     <para>
  
    </sect2>
--- 2462,2468 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.11,
!     see <xref linkend="release-8-2-11">.
     </para>
  
    </sect2>
***************
*** 2641,2647 ****
     <para>
!     see <xref linkend="release-8-2-7">.  Also, if you were running a previous
  
    </sect2>
--- 2825,2831 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
***************
*** 3057,3063 ****
     <para>
  
    </sect2>
--- 3057,3063 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
***************
*** 3124,3130 ****
     <para>
  
    </sect2>
--- 3124,3130 ----
     <para>
      A dump/restore is not required for those running 8.2.X.
      However, if you are upgrading from a version earlier than 8.2.7,
!     see <xref linkend="release-8-2-7">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 199,205 ****
  
     <para>
  
    </sect2>
--- 199,205 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 495,501 ****
  
     <para>
  
    </sect2>
--- 495,501 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 605,611 ****
  
     <para>
  
    </sect2>
--- 605,611 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 822,828 ****
  
     <para>
  
    </sect2>
--- 822,828 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 1051,1057 ****
  
     <para>
  
    </sect2>
--- 1051,1057 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.3.17,
!     see <xref linkend="release-8-3-17">.
     </para>
  
    </sect2>
***************
*** 1346,1352 ****
  
     <para>
  
    </sect2>
--- 1346,1352 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 1603,1609 ****
     <para>
  
    </sect2>
--- 1603,1609 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 1974,1980 ****
     <para>
  
    </sect2>
--- 1974,1980 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2137,2143 ****
     <para>
  
    </sect2>
--- 2137,2143 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2269,2275 ****
     <para>
  
    </sect2>
--- 2269,2275 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2547,2553 ****
     <para>
  
    </sect2>
--- 2547,2553 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 2910,2916 ****
     <para>
  
    </sect2>
--- 2910,2916 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3139,3145 ****
     <para>
  
    </sect2>
--- 3139,3145 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3466,3472 ****
     <para>
  
    </sect2>
--- 3466,3472 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.8,
!     see <xref linkend="release-8-3-8">.
     </para>
  
    </sect2>
***************
*** 3801,3807 ****
  
    </sect2>
--- 3801,3807 ----
      However, if you have any hash indexes on <type>interval</> columns,
      you must <command>REINDEX</> them after updating to 8.3.8.
      Also, if you are upgrading from a version earlier than 8.3.5,
!     see <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4089,4095 ****
     <para>
  
    </sect2>
--- 4089,4095 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4312,4318 ****
     <para>
  
    </sect2>
--- 4312,4318 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.5,
!     see <xref linkend="release-8-3-5">.
     </para>
  
    </sect2>
***************
*** 4606,4612 ****
     <para>
!     see <xref linkend="release-8-3-1">.  Also, if you were running a previous
  
    </sect2>
--- 4861,4867 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
***************
*** 5215,5221 ****
     <para>
  
    </sect2>
--- 5215,5221 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
***************
*** 5282,5288 ****
     <para>
  
    </sect2>
--- 5282,5288 ----
     <para>
      A dump/restore is not required for those running 8.3.X.
      However, if you are upgrading from a version earlier than 8.3.1,
!     see <xref linkend="release-8-3-1">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.17,
!     see <xref linkend="release-8-4-17">.
     </para>
  
    </sect2>
***************
*** 225,231 ****
  
     <para>
  
    </sect2>
--- 225,231 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.17,
!     see <xref linkend="release-8-4-17">.
     </para>
  
    </sect2>
***************
*** 432,438 ****
  
     <para>
  
    </sect2>
--- 432,438 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 654,660 ****
  
     <para>
  
    </sect2>
--- 654,660 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 864,870 ****
  
     <para>
  
    </sect2>
--- 864,870 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1166,1172 ****
  
     <para>
  
    </sect2>
--- 1166,1172 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1282,1288 ****
  
     <para>
  
    </sect2>
--- 1282,1288 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1516,1522 ****
  
     <para>
  
    </sect2>
--- 1516,1522 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 1801,1807 ****
  
     <para>
  
    </sect2>
--- 1801,1807 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.10,
!     see <xref linkend="release-8-4-10">.
     </para>
  
    </sect2>
***************
*** 2170,2176 ****
  
     <para>
  
    </sect2>
--- 2170,2176 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.8,
!     see <xref linkend="release-8-4-8">.
     </para>
  
    </sect2>
***************
*** 2478,2484 ****
  
     <para>
  
    </sect2>
--- 2478,2484 ----
  
     <para>
      However, if you are upgrading from a version earlier than 8.4.8,
!     see <xref linkend="release-8-4-8">.
     </para>
  
    </sect2>
***************
*** 3014,3020 ****
  
     <para>
  
    </sect2>
--- 3014,3020 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3248,3254 ****
     <para>
  
    </sect2>
--- 3248,3254 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3380,3386 ****
     <para>
  
    </sect2>
--- 3380,3386 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 3691,3697 ****
     <para>
  
    </sect2>
--- 3691,3697 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 4213,4219 ****
     <para>
  
    </sect2>
--- 4213,4219 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
***************
*** 4504,4510 ****
     <para>
  
    </sect2>
--- 4504,4510 ----
     <para>
      A dump/restore is not required for those running 8.4.X.
      However, if you are upgrading from a version earlier than 8.4.2,
!     see <xref linkend="release-8-4-2">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.13,
!     see <xref linkend="release-9-0-13">.
     </para>
  
    </sect2>
***************
*** 262,268 ****
  
     <para>
  
    </sect2>
--- 262,268 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.13,
!     see <xref linkend="release-9-0-13">.
     </para>
  
    </sect2>
***************
*** 535,541 ****
  
     <para>
  
    </sect2>
--- 535,541 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 825,831 ****
  
     <para>
  
    </sect2>
--- 825,831 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1087,1093 ****
  
     <para>
  
    </sect2>
--- 1087,1093 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1465,1471 ****
  
     <para>
  
    </sect2>
--- 1465,1471 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1607,1613 ****
  
     <para>
  
    </sect2>
--- 1607,1613 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 1913,1919 ****
  
     <para>
  
    </sect2>
--- 1913,1919 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 2233,2239 ****
  
     <para>
  
    </sect2>
--- 2233,2239 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.6,
!     see <xref linkend="release-9-0-6">.
     </para>
  
    </sect2>
***************
*** 2756,2762 ****
  
     <para>
  
    </sect2>
--- 2756,2762 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.0.4,
!     see <xref linkend="release-9-0-4">.
     </para>
  
    </sect2>
***************
*** 3133,3139 ****
  
     <para>
  
    </sect2>
--- 3133,3139 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.0.4,
!     see <xref linkend="release-9-0-4">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.9,
!     see <xref linkend="release-9-1-9">.
     </para>
  
    </sect2>
***************
*** 281,287 ****
  
     <para>
  
    </sect2>
--- 281,287 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.9,
!     see <xref linkend="release-9-1-9">.
     </para>
  
    </sect2>
***************
*** 623,629 ****
  
     <para>
  
    </sect2>
--- 623,629 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.6,
!     see <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 950,956 ****
  
     <para>
  
    </sect2>
--- 950,956 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 1272,1278 ****
  
     <para>
  
    </sect2>
--- 1272,1278 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.6,
!     see <xref linkend="release-9-1-6">.
     </para>
  
    </sect2>
***************
*** 1741,1747 ****
  
     <para>
  
    </sect2>
--- 1741,1747 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.4,
!     see <xref linkend="release-9-1-4">.
     </para>
  
    </sect2>
***************
*** 1990,1996 ****
  
     <para>
  
    </sect2>
--- 1990,1996 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.4,
!     see <xref linkend="release-9-1-4">.
     </para>
  
    </sect2>
***************
*** 2389,2395 ****
  
     <para>
  
    </sect2>
--- 2389,2395 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.1.2,
!     see <xref linkend="release-9-1-2">.
     </para>
  
    </sect2>
***************
*** 2867,2873 ****
  
     <para>
  
    </sect2>
--- 2867,2873 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.1.2,
!     see <xref linkend="release-9-1-2">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.4,
!     see <xref linkend="release-9-2-4">.
     </para>
  
    </sect2>
***************
*** 361,367 ****
  
     <para>
  
    </sect2>
--- 361,367 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.4,
!     see <xref linkend="release-9-2-4">.
     </para>
  
    </sect2>
***************
*** 780,786 ****
  
     <para>
  
    </sect2>
--- 780,786 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.2.2,
!     see <xref linkend="release-9-2-2">.
     </para>
  
    </sect2>
***************
*** 1180,1186 ****
  
     <para>
  
    </sect2>
--- 1180,1186 ----
  
     <para>
      However, if you are upgrading from a version earlier than 9.2.2,
!     see <xref linkend="release-9-2-2">.
     </para>
  
    </sect2>
***************
*** 1637,1643 ****
  
     <para>
  
    </sect2>
--- 1637,1643 ----
  
     <para>
      Also, if you are upgrading from version 9.2.0,
!     see <xref linkend="release-9-2-1">.
     </para>
  
    </sect2>
  
     <para>
  
    </sect2>
--- 30,36 ----
  
     <para>
      Also, if you are upgrading from a version earlier than 9.3.1,
!     see <xref linkend="release-9-3-1">.
     </para>
  
    </sect2>
*** a/doc/src/sgml/release-old.sgml
--- b/doc/src/sgml/release-old.sgml
***************
*** 25,32 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 25,32 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 130,137 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 130,137 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 192,199 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 192,199 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 248,255 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 248,255 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 309,316 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 309,316 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 365,372 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
    </sect2>
--- 365,372 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
    </sect2>
***************
*** 408,415 ****
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
  
     <para>
--- 408,415 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
  
     <para>
***************
*** 499,506 **** Fuhr)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13, see the release
!     notes for 7.3.13.
     </para>
    </sect2>
  
--- 499,506 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.13,
!     see <xref linkend="release-7-3-13">.
     </para>
    </sect2>
  
***************
*** 556,563 **** and <function>isinf</> during configure (Tom)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10, see the release
!     notes for 7.3.10.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
--- 556,563 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10,
!     see <xref linkend="release-7-3-10">.
      Also, you might need to <command>REINDEX</> indexes on textual
      columns after updating, if you are affected by the locale or
      <application>plperl</> issues described below.
***************
*** 618,625 **** what's actually returned by the query (Joe)</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10, see the release
!     notes for 7.3.10.
     </para>
    </sect2>
  
--- 618,625 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10,
!     see <xref linkend="release-7-3-10">.
     </para>
    </sect2>
  
***************
*** 665,672 **** table has been dropped</para></listitem>
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10, see the release
!     notes for 7.3.10.
     </para>
    </sect2>
  
--- 665,672 ----
  
     <para>
      A dump/restore is not required for those running 7.3.X.  However,
!     if you are upgrading from a version earlier than 7.3.10,
!     see <xref linkend="release-7-3-10">.
     </para>
    </sect2>

---

From: Vik Fearing <[email-masked]>
Date: Wed, 29 Jan 2014 15:20:11 +0100

On 01/20/2014 04:42 PM, Vik Fearing wrote:
>> [...]

I was hoping this could just be committed for the next batch of updates,
but since it hasn't been I have added it to CommitFest 2014-06 to
hopefully get it at least into 9.5.

https://commitfest.postgresql.org/action/patch_view?id=1405

-- 
Vik

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 11 Feb 2014 21:58:25 -0500

> one and it looks okay to me.

I think it would be even better to link directly to the migration notes,
not to the top-level section of the release notes.  I suggest to add a
link target like

  <sect2 id="release-9-2-4-migration">
   <title>Migration to Version 9.2.4</title>

and then link to that.

---

From: Tom Lane <[email-masked]>
Date: Wed, 12 Feb 2014 18:40:25 -0500

> and then link to that.

I experimented with this and didn't really find that it improved the
browsing experience any compared to what Vik did.  It might be noticeably
better if we had any significant amount of text above the "migration"
section, but we never do.

I'd prefer *not* to add yet another place where the version number
has to be manually adjusted each time one makes a new release-notes
section.  (This is a task we've failed at a few times in the past ;-),
so I'm not just hypothecating.)  So I'm -1 for this unless there's
really, really strong contrary opinion.

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Wed, 12 Feb 2014 16:04:42 -0800

> really, really strong contrary opinion.

Not to hijack the thread but after a decade and a half of writing 
release notes one would think that we would have a parser that goes 
through and automatically updates the version number :P

jD

-- 
Command Prompt, Inc. - http://www.commandprompt.com/  509-416-6579
PostgreSQL Support, Training, Professional Services and Development
High Availability, Oracle Conversion, Postgres-XC, @cmdpromptinc
For my dreams of your image that blossoms
    a rose in the deeps of my heart. - W.B. Yeats

---

From: Tom Lane <[email-masked]>
Date: Wed, 12 Feb 2014 19:25:29 -0500

> one and it looks okay to me.

Committed.  Thanks for doing what sure looks like a mind-numbingly
tedious bit of editing.

			regards, tom lane

---

From: Vik Fearing <[email-masked]>
Date: Thu, 13 Feb 2014 09:11:00 +0100

> Committed. Thanks for doing what sure looks like a mind-numbingly

Thank you for committing it!

-- 
Vik