Subject: 9.3 release notes and maintenance_work_mem

From: Joe Conway <[email-masked]>
Date: Thu, 24 Apr 2014 20:25:56 -0700

Shouldn't the reference to work_mem here:

"Allow in-memory sorts to use their full memory allocation (Jeff Janes)"
http://www.postgresql.org/docs/9.3/interactive/release-9-3.html#AEN114956

actually be referencing maintenance_work_mem?

Joe

- -- 
Joe Conway
credativ LLC: http://www.credativ.us
Linux, PostgreSQL, and general Open Source
Training, Service, Consulting, & 24x7 Support

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Joe Conway <[email-masked]>
Date: Thu, 24 Apr 2014 20:59:16 -0700

>  actually be referencing maintenance_work_mem?

Or I suppose, rather, shouldn't it be referring to both?

Joe

- -- 
Joe Conway

---

From: Tom Lane <[email-masked]>
Date: Fri, 25 Apr 2014 10:33:34 -0400

> Or I suppose, rather, shouldn't it be referring to both?

In principle I suppose someone might've set maintenance_work_mem with an
eye on the space needed to build specific indexes, but it seems relatively
unlikely compared to the work_mem scenario.  I think it'd just confuse
people to mention both parameters.

			regards, tom lane