Subject: Re: [pgsql-hackers-win32] Does "console code page" issue apply to MinGW, Cygwin builds?

From: "Magnus Hagander" <[email-masked]>
Date: Mon, 27 Dec 2004 09:48:22 +0100

> At the bottom of
> http://developer.postgresql.org/docs/postgres/install-win32.html
> there is some info about having to set the correct console 
> code page for psql.  Does this apply to the MinGW and/or 
> Cygwin builds, or is it only relevant for Visual C++ and 
> Borland C++ builds?  If the former, it's in the wrong place.  
> I am not sure what the right place is though.

It definitly applies to the MinGW build. Not sure about Cygwin.

//Magnus

---

From: Reini Urban <[email-masked]>
Date: Mon, 27 Dec 2004 18:21:53 +0100

> It definitly applies to the MinGW build. Not sure about Cygwin.

Cygwin ditto (see the note at the end), but previous cygwin builds (up 
to 7.4.5 if I remember correctly) had only limited codepage support.

If unsupported by your cygwin build it will complain on initdb and/or 
psql otherwise.
-- 
Reini Urban
http://xarch.tu-graz.ac.at/home/rurban/