Subject: pg_roles has a column rolconfig, but it's not documented.

From: SAKAMOTO Masahiko <[email-masked]>
Date: Tue, 28 Jun 2011 15:56:24 +0900

Hi,

I found that documentation on pg_roles should be updated.
pg_roles has a column "rolconfig", but it is missing.

attached should be back-patched also to 9.0, 8.4, 8.3, 8.2, and older.

Regards,

-- 

SAKAMOTO Masahiko
NIPPON TELEGRAPH AND TELEPHONE CORPORATION
NTT Open Source Software Center

diff --git a/doc/src/sgml/catalogs.sgml b/doc/src/sgml/catalogs.sgml
index 713ee25..be5ad71 100644
--- a/doc/src/sgml/catalogs.sgml
+++ b/doc/src/sgml/catalogs.sgml
@@ -7417,6 +7417,13 @@
      </row>
 
      <row>
+      <entry><structfield>rolconfig</structfield></entry>
+      <entry><type>text[]</type></entry>
+      <entry></entry>
+      <entry>Defaults for run-time configuration variables</entry>
+     </row>
+
+     <row>
       <entry><structfield>oid</structfield></entry>
       <entry><type>oid</type></entry>
       <entry><literal><link linkend="catalog-pg-authid"><structname>pg_authid</structname></link>.oid</literal></entry>

---

From: Tom Lane <[email-masked]>
Date: Sun, 03 Jul 2011 21:53:16 -0400

> attached should be back-patched also to 9.0, 8.4, 8.3, 8.2, and older.

Yeah, you're right ... and as of 9.1 we've also forgotten to document
rolreplication there :-(.  Will fix, thanks for the report!

			regards, tom lane