Subject: Fir mkdir command in "Short Version" for installing from source

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Sun, 13 Mar 2022 16:05:42 +0000

Hi,

if you follow that example step by step, the mkdir command will fail, obviously:
https://www.postgresql.org/docs/current/install-short.html

Is it worth fixing that with "mkdir -p ..."? 

Regards
Daniel

---

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 14 Mar 2022 10:08:05 +0100

> On 13 Mar 2022, at 17:05, Daniel Westermann (DWE) <[email-masked]> wrote:

> Is it worth fixing that with "mkdir -p ..."? 

Well, it will fail unless the user already had /usr/local/pgsql/, but I hear
what you're saying.  Though I bet almost anyone following this will be able to
figure it out but there is little to no value in not being correct.

--
Daniel Gustafsson		https://vmware.com/

---

From: Tom Lane <[email-masked]>
Date: Mon, 14 Mar 2022 10:01:32 -0400

> figure it out but there is little to no value in not being correct.

I think that at the time that was written, mkdir didn't universally
have a "-p" option.  But POSIX has required that for a very long
time, so it's probably safe to assume it now.

A larger issue is that blind "mkdir -p" may not produce the ownerships
and permissions you want for the parent directories.  That's not a
topic to get into in a one-line summary, though.

			regards, tom lane

---

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 14 Mar 2022 15:28:47 +0100

> On 14 Mar 2022, at 15:01, Tom Lane <[email-masked]> wrote:
> 

Yeah, I wasn't able to find any credibly still useable system man page which
didn't list -p.  (the fact that IRIX seems to have been one of very few to have
a long option '--parents' was an interesting archeological tidbit learned.)

> topic to get into in a one-line summary, though.

Agreed, we're skipping over lots of details in this short version.

I'll to make the mkdir -p change happen later today unless someone feels
strongly about leaving it out.

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Mon, 14 Mar 2022 14:54:25 +0000

>strongly about leaving it out.

Thank you Daniel and Tom
Regards
Daniel