Subject: Override sort order

From: Anthony Ananich <[email-masked]>
Date: Tue, 28 Jun 2016 14:31:02 +0300

Dear All,

I’ve got a need to change sort order for jsonb field. I’m looking for a way to change “order by” behavior like it is described in my previous question.

I’ve found a piece of doc which says that it is possible to override method “int compare(Datum a, Datum b)” here:
https://www.postgresql.org/docs/9.5/static/gin-extensibility.html

I wonder if there are any examples available? 

If not I’m opened to offer my help in making one.

Regards,
Anthony Ananich
http://ananich.pro

---

From: Anthony Ananich <[email-masked]>
Date: Tue, 28 Jun 2016 14:58:38 +0300

Just in case: by previous question I mean this one:
https://www.postgresql.org/message-id/[email-masked]