Subject: yet another release notes patch

From: Josh Berkus <[email-masked]>
Date: Thu, 24 Jun 2010 10:17:17 -0700

Bruce,

Still working on it ....

-- 
                                   -- Josh Berkus
                                      PostgreSQL Experts Inc.
                                      http://www.pgexperts.com
Index: release-9.0.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/release-9.0.sgml,v
retrieving revision 2.34
diff -c -r2.34 release-9.0.sgml
*** release-9.0.sgml	16 Jun 2010 18:46:18 -0000	2.34
--- release-9.0.sgml	24 Jun 2010 17:13:16 -0000
***************
*** 1,4 ****
! <!-- $PostgreSQL: pgsql/doc/src/sgml/release-9.0.sgml,v 2.34 2010/06/16 18:46:18 momjian Exp $ -->
  
   <sect1 id="release-9-0">
    <title>Release 9.0</title>
--- 1,4 ----
! <!-- $PostgreSQL: pgsql/doc/src/sgml/release-9.0.sgml,v 2.31 2010/06/14 02:18:43 rhaas Exp $ -->
  
   <sect1 id="release-9-0">
    <title>Release 9.0</title>
***************
*** 55,61 ****
        The <link linkend="SQL-DO"><command>DO</></link> statement permits
        ad-hoc or anonymous code blocks.  Functions can now be called using named
        parameters.  PL/pgSQL is now installed by default, and PL/Perl and PL/Python
!       have been enhanced in several ways.
       </para>
      </listitem>
  
--- 55,61 ----
        The <link linkend="SQL-DO"><command>DO</></link> statement permits
        ad-hoc or anonymous code blocks.  Functions can now be called using named
        parameters.  PL/pgSQL is now installed by default, and PL/Perl and PL/Python
!       have been enhanced in several ways, including support for Python3.
       </para>
      </listitem>
  
***************
*** 290,296 ****
     <title>PL/pgSQL Variables</title>
     <itemizedlist>
  
- 
      <listitem>
       <para>
        Have PL/pgSQL throw an error if a variable name conflicts with a
--- 290,295 ----
***************
*** 333,342 ****
--- 332,363 ----
     </itemizedlist>
  
    </sect3>
+ 
+   <sect3>
+    <title>Other Incompatibilities</title>
+    <itemizedlist>
+     <listitem>
+       <para>
+        Remove support for platforms that don't have a working 64-bit
+        integer data types (Tom Lane)
+       </para>
+ 
+       <para>
+        It is believed all supported platforms have working 64-bit integer
+        data types.
+       </para>
+      </listitem>
+     </itemizedlist>
+    </sect3>
   </sect2>
  
   <sect2>
    <title>Changes</title>
+    <para>
+     Version 9.0 has an unprecedented number of new major features, 
+     and over 200 enhancements, improvements, new commands,
+     new functions, and other changes.
+    </para>
  
    <sect3>
     <title>Server</title>
***************
*** 573,578 ****
--- 594,604 ----
  
     <sect4>
      <title>Authentication</title>
+     <para>
+      Version 9.0 further extends PostgreSQL's support for multiple
+      authentication methods, including RADIUS and improved LDAP support.
+     </para>
+ 
      <itemizedlist>
  
       <listitem>
***************
*** 624,629 ****
--- 650,661 ----
  
     <sect4>
      <title>Monitoring</title>
+     <para>
+      With increased use of PostgreSQL in high-end production systems, 
+      users need increased monitoring.  PostgresSQL 9.0 continues to add
+      more ways to monitor PostgreSQL applications.
+     </para>
+ 
      <itemizedlist>
  
       <listitem>
***************
*** 635,642 ****
        </para>
  
        <para>
!         This allows DBAs to characterize database traffic 
!         and troubleshoot problems by source application.
        </para>
       </listitem>
  
--- 667,674 ----
        </para>
  
        <para>
! 	This allows DBAs to characterize database traffic 
! 	and troubleshoot problems by source application.
        </para>
       </listitem>
  
***************
*** 646,651 ****
--- 678,689 ----
         linkend="guc-log-line-prefix"><varname>log_line_prefix</></link>
         (Guillaume Smet)
        </para>
+ 
+       <para>
+        This allows users to compile statistics on errors and messages
+        by type.
+       </para>
+ 
       </listitem>
  
       <listitem>
***************
*** 653,658 ****
--- 691,701 ----
         Write to the Windows event log in <acronym>UTF16</> encoding
         (Itagaki Takahiro)
        </para>
+ 
+       <para>
+        Now there is true multi-lingual support for PostgreSQL log messages
+        on Windows.
+       </para>
       </listitem>
  
      </itemizedlist>
***************
*** 704,710 ****
         <application>psql</> <literal>\drds</> command shows these settings.
         Backwards-compatible system views do not show this information.
         The primary use of this feature is setting schema 
!        <link linkend="guc-search-path"><varname>search_path</varname></link>.
        </para>

--- 747,753 ----
         <application>psql</> <literal>\drds</> command shows these settings.
         Backwards-compatible system views do not show this information.
         The primary use of this feature is setting schema 
!        <link linkend="guc-search_path"><varname>search_path</varname></link>.
        </para>

***************
*** 820,828 ****
       </para>
  
       <para>
!       This allows operations that do not return a result, like
!       <command>SELECT INTO</>, to return a count of the number of rows
!       processed.
       </para>
  
       <para>
--- 863,871 ----
       </para>
  
       <para>
!       For drivers which support this feature, this saves an entire 
!       round-trip to the client, allowing result counts and pagination
!       to be calculated without a second <command>COUNT</command> query.
       </para>
  
       <para>
***************
*** 1798,1803 ****
--- 1841,1858 ----
        </para>
       </listitem>
  
+      <listitem>
+       <para>
+        PL/Perl subroutines are now given perl-visible names (Tim Bunce)
+       </para>
+ 
+       <para>
+        PL/Perl subroutines are anonymous subrefs; this change adds entries 
+        to the Perl symbol table for them, making profiling and code coverage 
+        tools much more usable.
+       </para>
+      </listitem>
+ 
      </itemizedlist>
  
     </sect4>
***************
*** 2653,2658 ****
--- 2708,2727 ----
      <title>Binary Upgrade Support</title>
      <itemizedlist>
  
+     <listitem>
+      <para>
+       Add <link linkend="pgupgrade"><filename>/contrib/pg_upgrade</></link>
+       to support in-place upgrades (Bruce)
+      </para>
+ 
+      <para>
+       This avoids the requirement of dumping/reloading the database when
+       upgrading to a new major release of PostgreSQL and speeds up offline
+       upgrades by orders of magnitude. It supports upgrades to 9.0
+       from PostgreSQL 8.3 and 8.4.
+      </para>
+     </listitem>
+ 
       <listitem>
        <para>
         Add support for preservation of all <link
***************
*** 2696,2714 ****
  
      <listitem>
       <para>
-       Add <link linkend="pgupgrade"><filename>/contrib/pg_upgrade</></link>
-       to support in-place upgrades (Bruce)
-      </para>
- 
-      <para>
-       This avoids the requirement of dumping/reloading the database when
-       upgrading to a new major release of PostgreSQL.  It supports upgrades
-       from PostgreSQL 8.3 and 8.4.
-      </para>
-     </listitem>
- 
-     <listitem>
-      <para>
        Add multi-threaded option (<option>-j</>) to <link
        linkend="pgbench"><filename>/contrib/pgbench</></link>
        (Itagaki Takahiro)
--- 2765,2770 ----
***************
*** 2749,2755 ****
       </para>
  
       <para>
!       This filter dictionary removes accents from tokens.
       </para>
      </listitem>
  
--- 2805,2813 ----
       </para>
  
       <para>
!       This filter dictionary removes accents from tokens, and 
!       makes full-text searches over multiple languages much 
!       easier.
       </para>
      </listitem>
  
***************
*** 2775,2781 ****
       </para>
  
       <para>
!       New functions and operators were also added.
       </para>
      </listitem>
  
--- 2833,2840 ----
       </para>
  
       <para>
!       New functions and operators were also added.  These improvements
!       make HStore a full-functional key-value store embedded in PostgreSQL.
       </para>
      </listitem>

---

From: Robert Haas <[email-masked]>
Date: Thu, 24 Jun 2010 13:30:43 -0400

This part is no longer true:

+      <listitem>
+       <para>

http://archives.postgresql.org/pgsql-committers/2010-06/msg00159.php

...Robert

---

From: Josh Berkus <[email-masked]>
Date: Thu, 24 Jun 2010 10:54:31 -0700

> This part is no longer true:

Right.  And I just got an explanation of one of Oleg's patches.  Let me
submit a new doc patch if you haven't applied that one yet.

-- 
                                  -- Josh Berkus
                                     PostgreSQL Experts Inc.
                                     http://www.pgexperts.com

---

From: Robert Haas <[email-masked]>
Date: Thu, 24 Jun 2010 13:57:30 -0400

> submit a new doc patch if you haven't applied that one yet.

No, I have not applied.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise Postgres Company

---

From: Josh Berkus <[email-masked]>
Date: Thu, 24 Jun 2010 11:17:02 -0700

Robert,

Updated patch.

P.S. I hate CVS.

--- release-9.0.sgml	24 Jun 2010 18:10:19 -0000
  
   <sect1 id="release-9-0">
  
   <sect1 id="release-9-0">
  
--- 55,61 ----
  
***************
*** 290,296 ****
  
- 
      <listitem>
       <para>
  
    </sect3>
+ 
+   <sect3>
  
   <sect2>
    <title>Changes</title>
+    <para>
  
    <sect3>
     <title>Server</title>
***************
*** 573,578 ****
--- 594,604 ----
  
     <sect4>
  
       <listitem>
***************
*** 624,629 ****
--- 650,661 ----
  
     <sect4>
  
       <listitem>
***************
*** 635,642 ****
        </para>
  
        <para>
  
--- 667,674 ----
        </para>
  
        <para>
  
***************
*** 646,651 ****
--- 678,689 ----
  
       <listitem>
***************
*** 653,658 ****
--- 691,701 ----
  
      </itemizedlist>
***************
*** 704,710 ****

--- 747,753 ----

***************
*** 820,828 ****
       </para>
  
       <para>
  
       <para>
--- 863,871 ----
       </para>
  
       <para>
  
       <para>
***************
*** 1263,1269 ****
        </para>
  
        <para>
!        DETAILS?
        </para>
       </listitem>
  
--- 1306,1315 ----
        </para>
  
        <para>
!        This feature supports GiST indexing of point operations on polygons, 
!        circles, and other points, such as "point is in polygon".  Previously
!        indexing only worked for bounding boxes.  This should make many 
!        PostGIS queries faster.
        </para>
       </listitem>
  
***************
*** 2653,2658 ****
--- 2699,2718 ----
  
+     <listitem>
+      <para>
  
      <listitem>
       <para>
--- 2756,2761 ----
***************
*** 2749,2755 ****
       </para>
  
       <para>
  
--- 2796,2804 ----
       </para>
  
       <para>
  
***************
*** 2775,2781 ****
       </para>
  
       <para>
  
--- 2824,2831 ----
       </para>
  
       <para>

---

From: "Joshua D. Drake" <[email-masked]>
Date: Thu, 24 Jun 2010 11:30:09 -0700

> P.S. I hate CVS.

That's why were moving to GIT :P

-- 
PostgreSQL.org Major Contributor
Command Prompt, Inc: http://www.commandprompt.com/ - 509.416.6579
Consulting, Training, Support, Custom Development, Engineering

---

From: Robert Haas <[email-masked]>
Date: Thu, 24 Jun 2010 14:31:41 -0400

> Updated patch.

I'm applying this now, with the following corrections:

- change tabs back to spaces
- revert incorrect change of guc-search_path to guc-search-path

> P.S. I hate CVS.

So don't use it.

---

From: Robert Haas <[email-masked]>
Date: Thu, 24 Jun 2010 14:33:37 -0400

> - revert incorrect change of guc-search_path to guc-search-path

Or, actually, visca versa.

Committed now, with those changes.