Subject: number of semaphores and semaphore sets

From: Anton Yuzhaninov <[email-masked]>
Date: Mon, 21 Mar 2011 19:05:12 +0300

This page:
http://www.postgresql.org/docs/9.0/interactive/kernel-resources.html

has formula:
ceil((max_connections + autovacuum_max_workers) / 16)

for number of semaphore sets (identifiers).

It seems to be wrong (outdated).

Correct formula seems to be

ceil((max_connections + autovacuum_max_workers + 4) / 16)

Semaphore sets created in src/backend/storage/lmgr/proc.c:
1. MaxConnections
2. autovacuum_max_workers + 1
3. NUM_AUXILIARY_PROCS (currently 3)

-- 
  Anton Yuzhaninov

---

From: Robert Haas <[email-masked]>
Date: Tue, 5 Apr 2011 12:57:55 -0400

> 3. NUM_AUXILIARY_PROCS (currently 3)

Yeah, I think you're right.  It appears that nothing material has
changed here since 8.3, so I'm inclined to back-patch this doc fix
back that far.

Barring objections, I'll go change this.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 6 Sep 2011 11:08:51 -0400 (EDT)

> Barring objections, I'll go change this.

I have applied the attached patch and backpatched it to 9.0 and 9.1.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +
diff --git a/doc/src/sgml/runtime.sgml b/doc/src/sgml/runtime.sgml
new file mode 100644
index 5098aad..68ceff1
*** a/doc/src/sgml/runtime.sgml
--- b/doc/src/sgml/runtime.sgml
*************** psql: could not connect to server: No su
*** 604,616 ****
         <row>
          <entry><varname>SEMMNI</></>
          <entry>Maximum number of semaphore identifiers (i.e., sets)</>
!         <entry>at least <literal>ceil((max_connections + autovacuum_max_workers) / 16)</literal></>
         </row>
  
         <row>
          <entry><varname>SEMMNS</></>
          <entry>Maximum number of semaphores system-wide</>
!         <entry><literal>ceil((max_connections + autovacuum_max_workers) / 16) * 17</literal> plus room for other applications</>
         </row>
  
         <row>
--- 604,616 ----
         <row>
          <entry><varname>SEMMNI</></>
          <entry>Maximum number of semaphore identifiers (i.e., sets)</>
!         <entry>at least <literal>ceil((max_connections + autovacuum_max_workers + 4) / 16)</literal></>
         </row>
  
         <row>
          <entry><varname>SEMMNS</></>
          <entry>Maximum number of semaphores system-wide</>
!         <entry><literal>ceil((max_connections + autovacuum_max_workers + 4) / 16) * 17</literal> plus room for other applications</>
         </row>
  
         <row>
*************** psql: could not connect to server: No su
*** 685,691 ****
      linkend="sysvipc-parameters">).  The parameter <varname>SEMMNI</>
      determines the limit on the number of semaphore sets that can
      exist on the system at one time.  Hence this parameter must be at
!     least <literal>ceil((max_connections + autovacuum_max_workers) / 16)</>.
      Lowering the number
      of allowed connections is a temporary workaround for failures,
      which are usually confusingly worded <quote>No space
--- 685,691 ----
      linkend="sysvipc-parameters">).  The parameter <varname>SEMMNI</>
      determines the limit on the number of semaphore sets that can
      exist on the system at one time.  Hence this parameter must be at
!     least <literal>ceil((max_connections + autovacuum_max_workers + 4) / 16)</>.
      Lowering the number
      of allowed connections is a temporary workaround for failures,
      which are usually confusingly worded <quote>No space