Subject: SQL:2008 unsupported features

From: Thom Brown <[email-masked]>
Date: Tue, 21 Jun 2011 19:57:26 +0100

According to the docs
(http://www.postgresql.org/docs/9.1/static/unsupported-features-sql-standard.html),
PostgreSQL doesn't support feature set E081 of the SQL:2008 standard,
which includes:

E081-01	SELECT privilege at the table level
E081-02	DELETE privilege
E081-03	INSERT privilege at the table level
E081-04	UPDATE privilege at the table level
E081-05	UPDATE privilege at the column level
E081-06	REFERENCES privilege at the table level
E081-07	REFERENCES privilege at the column level
E081-08	WITH GRANT OPTION
E081-09	USAGE privilege
E081-10	EXECUTE privilege

Am I mistaken, but aren't all of these supported?

-- 
Thom Brown
Twitter: @darkixion
IRC (freenode): dark_ixion
Registered Linux user: #516935

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 21 Jun 2011 22:48:20 +0300

> Am I mistaken, but aren't all of these supported?

The USAGE privilege is not fully supported.

---

From: Thom Brown <[email-masked]>
Date: Tue, 21 Jun 2011 20:55:08 +0100

> The USAGE privilege is not fully supported.

Okay, so it only says E081 because there's part of it that it doesn't
conform with?  Now that I see the rest listed in the supported list
it's kind of obvious.

Thanks