Subject: Please help me to build docs on the latest 9.1

From: "MauMau" <[email-masked]>
Date: Sun, 15 May 2011 21:45:19 +0900

Hello,

I'm developing my first patch for PostgreSQL. The target is v9.2.

I'm trying to build HTML docs on Windows Vista (32-bit) with the latest v9.1 
Git branch, but the build fails. I followed the procedures in the v9.0 
manual. Could you tell me what might be the cause? The situation is as 
follows:

The latest commit on my Git repository that "git log -1" shows is:

--------------------------------------------------
commit 9bb6d9795253bb521f81c626fea49a704a369ca9
Author: Robert Haas <[email-masked]>
Date:   Fri May 13 15:47:31 2011 -0400

    More cleanup of FOREIGN TABLE permissions handling.
--------------------------------------------------

I could successfully build and install the program, do initdb, and 
start/stop the PostgreSQL server.

The whole content of src/tools/msvc/buildenv.pl is:

$ENV{M4} = 'C:\GNUWin32\bin\m4.exe';
$ENV{DOCROOT} = 'D:\pgdev\doctool';

I ran "builddoc.bat > out.txt 2>&1" in src/tools/msvc. I expected to get 
"html" directory in doc/src/sgml, but I couldn't get it after minutes of 
execution. The output of builddoc.bat contains some errors. I'll show the 
partial contents of out.txt below. The size of out.txt is too large (20.9MB) 
to attach. out.txt appears to contain all the HTML manual.

--------------------------------------------------
Hash %ENV missing the % in argument 1 of each() at -e line 1.
Hash %ENV missing the % in argument 1 of each() at -e line 1.
Can't open perl script "make-errcodes-table.pl": No such file or directory
Running first build...
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 
"http://www.w3.org/TR/html4/loose.dtd">
<HTML
><HEAD
><TITLE
>PostgreSQL 9.1beta1 Documentation</TITLE
><META
...
></BODY
></HTML
Running collateindex...
collateindex.pl: file "HTML.index" does not exist
Running second build...
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 
"http://www.w3.org/TR/html4/loose.dtd">
<HTML
><HEAD
><TITLE
>PostgreSQL 9.1beta1 Documentation</TITLE
><META
...
></BODY
></HTML

Docs build complete.
--------------------------------------------------

---

From: Robert Haas <[email-masked]>
Date: Mon, 13 Jun 2011 11:08:58 -0400

2011/5/15 MauMau <[email-masked]>:
> The latest commit on my Git repository that "git log -1" shows is.

I believe Andrew has fixed this problem.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: "MauMau" <[email-masked]>
Date: Tue, 14 Jun 2011 07:35:18 +0900

From: "Robert Haas" <[email-masked]>
> I believe Andrew has fixed this problem.

Yes, I made sure and reported to pgsql-hackers on May 25 that the 
builddoc.pl Andrew kindly created worked successfully.

Regards
MauMau