Subject: Migration page is out of date

From: Josh Berkus <[email-masked]>
Date: Tue, 22 Mar 2011 09:56:16 -0700

http://www.postgresql.org/docs/9.0/static/migration.html

This page:

a) has insufficient coverage of pg_upgrade
b) ignores parallel pg_restore
c) piping pg_dump is by no means always the fastest method

I'll write up a new version later, just wanted to put this note on the
ML so that somebody would bug me before the end of 9.1 beta.

-- 
                                  -- Josh Berkus
                                     PostgreSQL Experts Inc.
                                     http://www.pgexperts.com

---

From: Susanne Ebrecht <[email-masked]>
Date: Thu, 24 Mar 2011 08:59:35 +0100

Hello Josh,

> ML so that somebody would bug me before the end of 9.1 beta.

I really could hug you for this warning.

I am translating backup.sgml at the moment.

Means, I will stop after PITR and will wait before I will translate the 
rest of the file.
Wait means - I will start to translate another topic first.

Susanne

-- 
Susanne Ebrecht - 2ndQuadrant
PostgreSQL Development, 24x7 Support, Training and Services
www.2ndQuadrant.com

---

From: Robert Haas <[email-masked]>
Date: Sun, 3 Apr 2011 20:38:55 -0400

> ML so that somebody would bug me before the end of 9.1 beta.

Hey, you!

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 6 Sep 2011 12:40:54 -0400 (EDT)

> > ML so that somebody would bug me before the end of 9.1 beta.

I am not sure if you were aware that I re-did the upgrade section of the
docs to clearly mention pg_upgrade and other issues:

	http://www.postgresql.org/docs/9.1/static/upgrading.html

I am not sure how to mention parallel pg_restore when pg_dumpall can't
be used in parallel restore mode.

Any suggested changes?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +

---

From: Josh Berkus <[email-masked]>
Date: Thu, 08 Sep 2011 11:09:23 -0700

>>> ML so that somebody would bug me before the end of 9.1 beta.

Well, a bit late now.   Clearly posting stuff to the -docs list is not a
good way for me to remember it.

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com