Subject: synchronous_standby_names and hot_standby_feedback

From: Fujii Masao <[email-masked]>
Date: Mon, 13 Jun 2011 19:29:03 +0900

Hi,

The GucContext of synchronous_standby_names and hot_standby_feedback
is PGC_SIGHUP, so the following should be added into the explanations about
those parameters. Attached patch does that.

---------------------
This parameter can only be set in the <filename>postgresql.conf</>
file or on the server command line.
---------------------

Regards,

-- 
Fujii Masao
NIPPON TELEGRAPH AND TELEPHONE CORPORATION
NTT Open Source Software Center
*** a/doc/src/sgml/config.sgml
--- b/doc/src/sgml/config.sgml
***************
*** 2107,2112 **** SET ENABLE_SEQSCAN TO OFF;
--- 2107,2116 ----
          <xref linkend="guc-synchronous-commit"> parameter to
          <literal>local</> or <literal>off</>.
         </para>
+        <para>
+         This parameter can only be set in the <filename>postgresql.conf</>
+         file or on the server command line.
+        </para>
        </listitem>
       </varlistentry>
  
***************
*** 2239,2246 **** SET ENABLE_SEQSCAN TO OFF;
          about queries currently executing on the standby. This parameter can
          be used to eliminate query cancels caused by cleanup records, but
          can cause database bloat on the primary for some workloads.
!         The default value is <literal>off</literal>.  Feedback messages will not
!         be sent more frequently than once per <varname>wal_receiver_status_interval</>.
         </para>
        </listitem>
       </varlistentry>
--- 2243,2252 ----
          about queries currently executing on the standby. This parameter can
          be used to eliminate query cancels caused by cleanup records, but
          can cause database bloat on the primary for some workloads.
!         Feedback messages will not be sent more frequently than once per
!         <varname>wal_receiver_status_interval</>. The default value is
!         <literal>off</literal>. This parameter can only be set in the
!         <filename>postgresql.conf</> file or on the server command line.
         </para>
        </listitem>
       </varlistentry>

---

From: Robert Haas <[email-masked]>
Date: Mon, 13 Jun 2011 12:26:03 -0400

> those parameters. Attached patch does that.

Committed.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company