Subject: Re: create foreign table

From: Ray Stell <[email-masked]>
Date: Thu, 15 Sep 2011 12:51:57 -0400

On Thu, Sep 15, 2011 at 06:43:59AM -0500, Robert Haas wrote:
>> On Mon, Sep 12, 2011 at 8:42 AM, Ray Stell <[email-masked]> wrote:
>> > http://www.postgresql.org/docs/9.1/static/sql-createforeigntable.html
>> > It would be helpful if "SERVER" was defined if the parameters list
>> > on this page.
>>
>> We don't usually document required keywords - they're just required.
>> We do document the meaning of server_name, which I think is probably
>> what you were after.
>>
>> --
>> Robert Haas
>> EnterpriseDB: http://www.enterprisedb.com
>> The Enterprise PostgreSQL Company
>
>
>Thanks, Robert.
>
>Maybe if you just added a pointer to the "CREATE SERVER" command in
>your definition of server_name it would provide a bread crumb.
>

Oh, I see my mistake.  Maybe the inclusion of a link to "CREATE SERVER"
http://www.postgresql.org/docs/9.1/static/sql-createserver.html in the
server_name definition would be helpful, just like in the data_type line.
I was having trouble making the leap since the idea was a new one on me.

different topic 1:

When I put the word "foreign" in the search area on this page
http://www.postgresql.org/docs/9.1/static/index.html
it does not find create foreign table.

different topic 2:
 
Is there a way to know what chapter you are in when on any page of the docs?
Maybe add to the navigation line at the top:

Home -> Documentation -> Manuals -> PostgreSQL 9.1 -> PUT YOUR CHAPTER HERE?

like this:

Home -> Documentation -> Manuals -> PostgreSQL 9.1 -> I. SQL Commands

---

From: Robert Haas <[email-masked]>
Date: Mon, 19 Sep 2011 15:01:55 -0400

> it does not find create foreign table.

Yes.  AFAICT, somehow that search has become hopelessly broken.  It
doesn't seem to find anything.  I am pretty sure that it did before.

> Home -> Documentation -> Manuals -> PostgreSQL 9.1 -> I. SQL Commands

That's not a bad idea either.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 15 Aug 2012 20:38:36 -0400

> I was having trouble making the leap since the idea was a new one on me.

I have done as you suggested with the attached patch which will appear
in Postgres 9.3.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +
diff --git a/doc/src/sgml/ref/create_foreign_table.sgml b/doc/src/sgml/ref/create_foreign_table.sgml
new file mode 100644
index 2113d00..f860ad0
*** a/doc/src/sgml/ref/create_foreign_table.sgml
--- b/doc/src/sgml/ref/create_foreign_table.sgml
*************** CREATE FOREIGN TABLE [ IF NOT EXISTS ] <
*** 135,141 ****
      <listitem>
       <para>
        The name of an existing server for the foreign table.
!      </para>
      </listitem>
     </varlistentry>
  
--- 135,142 ----
      <listitem>
       <para>
        The name of an existing server for the foreign table.
!       For details on defining a server, see <xref
!       linkend="SQL-CREATESERVER">.
      </listitem>
     </varlistentry>