Subject: Small correction in http://www.postgresql.org/docs/9.0/interactive/wal-reliability.html

From: Achilleas Mantzios <[email-masked]>
Date: Fri, 17 Jun 2011 14:55:45 +0300

It reads :
'On FreeBSD, IDE drives can be queried using atacontrol, and SCSI drives using sdparm. '
but it should be:
'On FreeBSD, IDE drives can be queried using atacontrol, and SCSI drives using camcontrol. '
-- 
Achilleas Mantzios

---

From: Greg Smith <[email-masked]>
Date: Fri, 17 Jun 2011 22:54:09 -0400

On 06/17/2011 07:55 AM, Achilleas Mantzios wrote:
> It reads :
> 'On FreeBSD, IDE drives can be queried using atacontrol, and SCSI drives using sdparm.'
> but it should be:
> 'On FreeBSD, IDE drives can be queried using atacontrol, and SCSI drives using camcontrol.'
>    

FreeBSD's Common Access Method (CAM) looks to be the preferred driver 
layer to interrogate.  sdparm is available on Linux and FreeBSD, but 
it's a second-class citizen talking to CAM on the latter.  To quote from 
one of the docs on it, FreeBSD sdparm "SCSI commands are routed through 
the CAM pass-through interface".  Talking directly to it with camcontrol 
does seem to be the preferred route for some things.

However, the UI to sdparm is a bit easier to use when it is available.  
Actually changing the write cache state with camcontrol requires black 
magic--you have to construct the right SCSI packet by hand.  I can't 
find any example.

Bruce just touched this section of the docs recently, so this part 
actually reads just:

          SCSI drives use <command>sdparm</command>.

Now.  Perhaps the following makes sense:

          SCSI drives can be queried using <command> camcontrol 
identify</command>, and the write cache both queried and changed using 
<command>sdparm</command> when available.

-- 
Greg Smith   2ndQuadrant US    [email-masked]   Baltimore, MD
PostgreSQL Training, Services, and 24x7 Support  www.2ndQuadrant.us

---

From: Robert Haas <[email-masked]>
Date: Mon, 10 Oct 2011 13:27:26 -0400

On Fri, Jun 17, 2011 at 10:54 PM, Greg Smith <[email-masked]> wrote:
> FreeBSD's Common Access Method (CAM) looks to be the preferred driver layer
> to interrogate.  sdparm is available on Linux and FreeBSD, but it's a
> second-class citizen talking to CAM on the latter.  To quote from one of the
> docs on it, FreeBSD sdparm "SCSI commands are routed through the CAM
> pass-through interface".  Talking directly to it with camcontrol does seem
> to be the preferred route for some things.
>
> magic--you have to construct the right SCSI packet by hand.  I can't find
> any example.
>
> Bruce just touched this section of the docs recently, so this part actually
> reads just:
>

Done, in master and REL9_1_STABLE.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company