Subject: 9.3: mention checksum feature in "29.1. Reliability"

From: Ian Lawrence Barwick <[email-masked]>
Date: Tue, 27 Aug 2013 13:31:45 +0900

This page:

  http://www.postgresql.org/docs/9.3/static/wal-reliability.html

says:

"Data pages are not currently checksummed, though full page images
recorded in WAL records will be protected. Data pages have a 16-bit
field available for future use with a data page checksum feature."

Patch with correction suggestion attached.

Regards

Ian Barwick

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Simon Riggs <[email-masked]>
Date: Tue, 27 Aug 2013 10:18:32 +0100

> Patch with correction suggestion attached.

Thanks Ian, well spotted.

-- 
 Simon Riggs                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 31 Jan 2014 19:05:48 -0500

> Patch with correction suggestion attached.

Modified patch attached and applied.  Backpatched to 9.3.  Thanks.  I
removed the mention of 9.3 because that looks odd after a few releases.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +
diff --git a/doc/src/sgml/wal.sgml b/doc/src/sgml/wal.sgml
new file mode 100644
index 059697e..c722532
*** a/doc/src/sgml/wal.sgml
--- b/doc/src/sgml/wal.sgml
***************
*** 193,201 ****
      </listitem>
      <listitem>
       <para>
!       Data pages are not currently checksummed, though full page images recorded
!       in WAL records will be protected. Data pages have a 16-bit field available
!       for future use with a data page checksum feature.
       </para>
      </listitem>
      <listitem>
--- 193,202 ----
      </listitem>
      <listitem>
       <para>
!       Data pages are not currently checksummed by default, though full page images
!       recorded in WAL records will be protected;  see<link
!       linkend="app-initdb-data-checksums"><application>initdb</></link>
!       for details about enabling data page checksums.
       </para>
      </listitem>
      <listitem>