Subject: Foreign server version and type

From: Thom Brown <[email-masked]>
Date: Mon, 15 Aug 2011 17:58:00 +0100

Hi,

I'm looking at the CREATE SERVER page on the documentation (
http://www.postgresql.org/docs/9.1/static/sql-createserver.html) and noticed
that there's a server_version parameter which can be provided with the
keyword VERSION and server_type specified after TYPE.

However, there's zero information about what these are used for, whether
they have any bearing on anything or why you'd want to use them.  Are these
parameters used for anything, or are they purely for future functionality?
 Whatever the case, could some kind of elaboration be added to justify the
existence of these options?  They have been in the docs since the CREATE
SERVER syntax was introduced in 8.4.

Thanks

-- 
Thom Brown
Twitter: @darkixion
IRC (freenode): dark_ixion
Registered Linux user: #516935

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Heikki Linnakangas <[email-masked]>
Date: Mon, 15 Aug 2011 20:36:36 +0300

> SERVER syntax was introduced in 8.4.

It's in the SQL spec. It isn't used anything by PostgreSQL itself, but a 
wrapper could look at it. It would probably be good to say that 
explicitly in the docs.

-- 
   Heikki Linnakangas
   EnterpriseDB   http://www.enterprisedb.com

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 15 Aug 2012 11:47:41 -0400

On Mon, Aug 15, 2011 at 08:36:36PM +0300, Heikki Linnakangas wrote:
> It's in the SQL spec. It isn't used anything by PostgreSQL itself,
> but a wrapper could look at it. It would probably be good to say
> that explicitly in the docs.

I have applied the attached patch to document that these fields are only
potentially useful to foreign data wrappers.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +
diff --git a/doc/src/sgml/ref/create_server.sgml b/doc/src/sgml/ref/create_server.sgml
new file mode 100644
index be9be50..60744b2
*** a/doc/src/sgml/ref/create_server.sgml
--- b/doc/src/sgml/ref/create_server.sgml
*************** CREATE SERVER <replaceable class="parame
*** 69,75 ****
      <term><replaceable class="parameter">server_type</replaceable></term>
      <listitem>
       <para>
!       Optional server type.
       </para>
      </listitem>
     </varlistentry>
--- 69,75 ----
      <term><replaceable class="parameter">server_type</replaceable></term>
      <listitem>
       <para>
!       Optional server type, potentially useful to foreign-data wrappers.
       </para>
      </listitem>
     </varlistentry>
*************** CREATE SERVER <replaceable class="parame
*** 78,84 ****
      <term><replaceable class="parameter">server_version</replaceable></term>
      <listitem>
       <para>
!       Optional server version.
       </para>
      </listitem>
     </varlistentry>
--- 78,84 ----
      <term><replaceable class="parameter">server_version</replaceable></term>
      <listitem>
       <para>
!       Optional server version, potentially useful to foreign-data wrappers.
       </para>
      </listitem>
     </varlistentry>

---

From: Thom Brown <[email-masked]>
Date: Wed, 15 Aug 2012 16:50:54 +0100

> potentially useful to foreign data wrappers.

Thanks Bruce, and a very belated thanks to Heikki for the explanation.

-- 
Thom