Subject: Logical Replication upgrade

From: PG Doc comments form <[email-masked]>
Date: Mon, 13 Apr 2026 15:06:27 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/logical-replication-upgrade.html
Description:

Hello there,

I don't know if it's me but I find this sentence quite confusing in its
current wording:
All slots on the old cluster must be usable, i.e., there are no slots whose
pg_replication_slots.conflicting is not true.

The prerequisite is that no replication slot has conflicting=true right?
So this sentence (the i.e. part) suggests the opposite, as per my
understanding.

Here is the link (29.13.1):
https://www.postgresql.org/docs/current/logical-replication-upgrade.html#STEPS-TWO-NODE-CIRCULAR-LOGICAL-REPLICATION-CLUSTER:~:text=there%20are%20no%20slots%20whose%20pg_replication_slots.conflicting%20is%20not%20true

Thanks.
Regards,

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 15 Apr 2026 08:55:20 -0700

> https://www.postgresql.org/docs/current/logical-replication-upgrade.html#STEPS-TWO-NODE-CIRCULAR-LOGICAL-REPLICATION-CLUSTER:~:text=there%20are%20no%20slots%20whose%20pg_replication_slots.conflicti…
You are correct.  Usage of a double-negative should be avoided as a matter
of style, but in this case it actually resolves to an untrue statement.

https://github.com/postgres/postgres/commit/7fdeaf5774d05245e82632e763665ff62db5598e

I've copied the committer for this.  Removing the "not" is simple enough;
though writing in the negative sense, while good for an SQL where clause,
does make reading in English more difficult.  Would rather say "all slots
must be false" rather than "no slots can be true".  The next item regarding
no persistent slots has the same complaint though it is factually correct
as written.  Though NULL is a valid value here so maybe the negative
phrasing is indeed necessary...

David J.

---

From: Amit Kapila <[email-masked]>
Date: Thu, 16 Apr 2026 08:34:34 +0530

On Wed, Apr 15, 2026 at 9:25 PM David G. Johnston
<[email-masked]> wrote:
>
> On Wed, Apr 15, 2026 at 7:52 AM PG Doc comments form <[email-masked]> wrote:
>>
> You are correct.  Usage of a double-negative should be avoided as a matter of style, but in this case it actually resolves to an untrue statement.
>
> I've copied the committer for this.  Removing the "not" is simple enough; though writing in the negative sense,
>

How about: "All slots on the old cluster must be usable, i.e., there
are no slots whose pg_replication_slots.conflicting is false."?

-- 
With Regards,
Amit Kapila.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 15 Apr 2026 20:29:35 -0700

On Wednesday, April 15, 2026, Amit Kapila <[email-masked]> wrote:

> >> https://www.postgresql.org/docs/current/logical-
> replication-upgrade.html#STEPS-TWO-NODE-CIRCULAR-
> LOGICAL-REPLICATION-CLUSTER:~:text=there%20are%20no%20slots%
> 20whose%20pg_replication_slots.conflicting%20is%20not%20true
> >>
> >
> > You are correct.  Usage of a double-negative should be avoided as a
> matter of style, but in this case it actually resolves to an untrue
> statement.
> >
> > I've copied the committer for this.  Removing the "not" is simple
> enough; though writing in the negative sense,
> >
>

That is the same backwards outcome.  You only replaced “not true” with
“false” (same meaning) but didn’t change the “no slots” phrasing.

You can write either?

No slots are true (conflicting)
All slots are false (not conflicting)

I prefer the second, and the fact your attempted fix didn’t actually fix
things suggests that rephrasing both of these to “all slots are” is better.

David J.

---

From: Amit Kapila <[email-masked]>
Date: Thu, 16 Apr 2026 10:43:52 +0530

On Thu, Apr 16, 2026 at 8:59 AM David G. Johnston
<[email-masked]> wrote:
> That is the same backwards outcome.  You only replaced “not true” with “false” (same meaning) but didn’t change the “no slots” phrasing.
>

Right, I got confused.

> I prefer the second, and the fact your attempted fix didn’t actually fix things suggests that rephrasing both of these to “all slots are” is better.
>

So, how about: "All slots on the old cluster must be usable, i.e.,
their pg_replication_slots.conflicting is false."?

-- 
With Regards,
Amit Kapila.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 15 Apr 2026 22:46:06 -0700

> their pg_replication_slots.conflicting is false."?

That works.

Then we’d also change:

The new cluster must not have permanent logical slots, i.e., there must be
no slots where pg_replication_slots.temporary is false.

To be:

“The new cluster is only permitted to have temporary logical slots, i.e.,
ones where pg_replication_slots.temporary is true.”

We could make it mirror the above one more closely, but as the former
mentions the old cluster and the later the new one, I kinda like the
different flow, less likely to skim over it.

David J.

---

From: vignesh C <[email-masked]>
Date: Thu, 16 Apr 2026 12:39:09 +0530

On Thu, 16 Apr 2026 at 11:16, David G. Johnston
<[email-masked]> wrote:
> The new cluster must not have permanent logical slots, i.e., there must be no slots where pg_replication_slots.temporary is false.
>
> To be:
>
> “The new cluster is only permitted to have temporary logical slots, i.e., ones where pg_replication_slots.temporary is true.”

+1 for this, the attached patch has the changes for the same.

Regards,
Vignesh

---

From: Amit Kapila <[email-masked]>
Date: Fri, 17 Apr 2026 09:24:47 +0530

> “The new cluster is only permitted to have temporary logical slots, i.e., ones where pg_replication_slots.temporary is true.”

What you wrote is correct but it is better to keep what is not allowed
for this case. Based on that, how about the following:
"The new cluster must not have any permanent logical slots; i.e., any
existing logical slots must have pg_replication_slots.temporary set to
true."

-- 
With Regards,
Amit Kapila.

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 16 Apr 2026 21:29:09 -0700

On Thu, Apr 16, 2026 at 8:55 PM Amit Kapila <[email-masked]> wrote:

> > The new cluster must not have permanent logical slots, i.e., there must
> be no slots where pg_replication_slots.temporary is false.
> >
> > To be:
> >
> > “The new cluster is only permitted to have temporary logical slots,
> i.e., ones where pg_replication_slots.temporary is true.”
> >
>
I was like 51/49 for flipping that around, so sure.

David J.

---

From: vignesh C <[email-masked]>
Date: Fri, 17 Apr 2026 11:02:16 +0530

> existing logical slots must have pg_replication_slots.temporary set to

Your version seems better, the attached v2 version patch has the
changes for the same.

Regards,
Vignesh