Subject: startup message -> StartupMessage

From: Dmitry Igrishin <[email-masked]>
Date: Thu, 9 Jun 2016 15:38:40 +0300

Hi,

At https://www.postgresql.org/docs/9.6/static/protocol-flow.html
The StartupMessage instead of "startup message" may looks better for
the reader (at least for me).

-- 
// Dmitry.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 22 Jun 2016 18:53:18 -0400

> the reader (at least for me).

Uh, where exactly?  Here?

	To begin a session, a frontend opens a connection to the server and
	sends a startup message.

In that case, it is highlighting it is a startup message, not the exact
message identifier.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I. As I am, so you will be. +
+                     Ancient Roman grave inscription +

---

From: Dmitry Igrishin <[email-masked]>
Date: Thu, 23 Jun 2016 07:47:10 +0300

>> the reader (at least for me).
I suggest everywhere on this page.
> In that case, it is highlighting it is a startup message, not the exact
Yes, but see the next sentence: "This message includes the names of
the user and of the database the user wants to connect to; it also
identifies the particular protocol version to be used." So, it's about
the StartupMessage exactly.

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 23 Jun 2016 09:24:33 -0400

> the StartupMessage exactly.

OK, how is this attached doc patch?

+ As you are, so once was I. As I am, so you will be. +
+                     Ancient Roman grave inscription +
diff --git a/doc/src/sgml/protocol.sgml b/doc/src/sgml/protocol.sgml
new file mode 100644
index 9c96d8f..04d6780
*** a/doc/src/sgml/protocol.sgml
--- b/doc/src/sgml/protocol.sgml
***************
*** 93,99 ****
     length of the rest of the message (this length count includes itself, but
     not the message-type byte).  The remaining contents of the message are
     determined by the message type.  For historical reasons, the very first
!    message sent by the client (the startup message) has no initial
     message-type byte.
    </para>
  
--- 93,99 ----
     length of the rest of the message (this length count includes itself, but
     not the message-type byte).  The remaining contents of the message are
     determined by the message type.  For historical reasons, the very first
!    message sent by the client (StartupMessage) has no initial
     message-type byte.
    </para>
  
***************
*** 213,221 ****
  
     <para>
      To begin a session, a frontend opens a connection to the server and sends
!     a startup message.  This message includes the names of the user and of the
      database the user wants to connect to; it also identifies the particular
!     protocol version to be used.  (Optionally, the startup message can include
      additional settings for run-time parameters.)
      The server then uses this information and
      the contents of its configuration files (such as
--- 213,222 ----
  
     <para>
      To begin a session, a frontend opens a connection to the server and sends
!     a startup message (StartupMessage).  This message includes the names
!     of the user and of the
      database the user wants to connect to; it also identifies the particular
!     protocol version to be used.  (Optionally, StartupMessage can include
      additional settings for run-time parameters.)
      The server then uses this information and
      the contents of its configuration files (such as

---

From: Tom Lane <[email-masked]>
Date: Thu, 23 Jun 2016 09:38:19 -0400

> OK, how is this attached doc patch?

I do not think these are improvements.  This is introductory text,
not some kind of formal-language specification.

			regards, tom lane

---

From: Dmitry Igrishin <[email-masked]>
Date: Thu, 23 Jun 2016 17:23:44 +0300

> not some kind of formal-language specification.
I can agree with this asserting when the text points to some abstract
message, like "The server then sends an appropriate authentication
request message" (because there are several kinds of authentication
messages). But for the concrete messages, there are consistency like
"The frontend must now send a PasswordMessage containing the
password", or "in the normal case the backend will send some
ParameterStatus messages", except the "During this phase the backend
will attempt to apply any additional run-time parameter settings that
were given in the startup message."

-- 
// Dmitry.