Subject: Documentation on Streaming Replication interface for Logical Decoding

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 9 Nov 2015 23:40:27 +0100

In section 46.3 (Streaming Replication Protocol Interface) the create command
for logical slots, CREATE_REPLICATION_SLOT, is defined as taking “options”
after the LOGICAL keyword when it in fact requires the plugin name.  The start
command is correctly listing the options but isn’t listing the required start
position.

The attached patch synchronizes these command signatures with the more detailed
descriptions in section 50.3* (Streaming Replication Protocol).

	cheers ./daniel

(*) Section number from the 9.5beta1 manual

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Michael Paquier <[email-masked]>
Date: Tue, 10 Nov 2015 13:59:27 +0900

> (*) Section number from the 9.5beta1 manual

Why do we need to maintain the semantics of those commands in two
places by the way? There is already a link to the replication protocol
page in logicaldecoding.sgml, hence it seems to me that we had better
just cite the command names, per se the attached.
-- 
Michael
diff --git a/doc/src/sgml/logicaldecoding.sgml b/doc/src/sgml/logicaldecoding.sgml
index 02794cc..11fc715 100644
--- a/doc/src/sgml/logicaldecoding.sgml
+++ b/doc/src/sgml/logicaldecoding.sgml
@@ -277,23 +277,11 @@ $ pg_recvlogical -d postgres --slot test --drop-slot
    <title>Streaming Replication Protocol Interface</title>
 
    <para>
-    The commands
-    <itemizedlist>
-     <listitem>
-      <para><literal>CREATE_REPLICATION_SLOT <replaceable>slot_name</replaceable> LOGICAL <replaceable>options</replaceable></literal></para>
-     </listitem>
-
-     <listitem>
-      <para><literal>DROP_REPLICATION_SLOT <replaceable>slot_name</replaceable></literal></para>
-     </listitem>
-
-     <listitem>
-      <para><literal>START_REPLICATION SLOT <replaceable>slot_name</replaceable> LOGICAL <replaceable>options</replaceable></literal></para>
-     </listitem>
-    </itemizedlist>
-    are used to create, drop, and stream changes from a replication
-    slot, respectively. These commands are only available over a replication
-    connection; they cannot be used via SQL.
+    The commands <literal>CREATE_REPLICATION_SLOT</literal>,
+    <literal>DROP_REPLICATION_SLOT</literal> and 
+    <literal>START_REPLICATION SLOT</literal> are used to create, drop, and
+    stream changes from a replication slot, respectively. These commands are
+    only available over a replication connection; they cannot be used via SQL.
     See <xref linkend="protocol-replication"> for details on these commands.
    </para>

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 10 Nov 2015 07:47:08 +0100

> On 10 Nov 2015, at 05:59, Michael Paquier <[email-masked]> wrote:
> 

Thats a perfectly reasonable approach as well, admittedly I don’t see much
point in the duplication.

	cheers ./daniel