Subject: [doc] EXPLAIN CREATE MATERIALIZED VIEW AS?

From: Amit Langote <[email-masked]>
Date: Wed, 16 Apr 2014 12:35:26 +0900

Hi,

Attached adds CREATE MATERIALIZED VIEW AS to the list of statements
that can be EXPLAINed.

--
Amit

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Michael Paquier <[email-masked]>
Date: Wed, 16 Apr 2014 13:56:27 +0900

> Attached adds CREATE MATERIALIZED VIEW AS to the list of statements
Now that you mention that, REFRESH MATERIALIZED VIEW can be EXPLAIN'ed
as well, except that it returns that and does not error out:
=# explain refresh materialized view aam;
                QUERY PLAN
-------------------------------------------
 Utility statements have no plan structure
(1 row)
-- 
Michael

-- 
Sent via pgsql-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 22 Apr 2014 18:38:25 -0400

> Attached adds CREATE MATERIALIZED VIEW AS to the list of statements

Patch applied.  Thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +