Subject: pg_rewind option clarification

From: Bruce Momjian <[email-masked]>
Date: Fri, 17 Jun 2016 11:51:08 -0400

This patch clarifies the documentation for when --source-pgdata and
--source-server can be used.

I would like to apply this to 9.6.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I. As I am, so you will be. +
+                     Ancient Roman grave inscription +
diff --git a/doc/src/sgml/ref/pg_rewind.sgml b/doc/src/sgml/ref/pg_rewind.sgml
new file mode 100644
index afcc9b7..41bc4f2
*** a/doc/src/sgml/ref/pg_rewind.sgml
--- b/doc/src/sgml/ref/pg_rewind.sgml
*************** PostgreSQL documentation
*** 122,129 ****
        <listitem>
         <para>
          Specifies path to the data directory of the source server, to
!         synchronize the target with. When <option>--source-pgdata</> is
!         used, the source server must be cleanly shut down.
         </para>
        </listitem>
       </varlistentry>
--- 122,129 ----
        <listitem>
         <para>
          Specifies path to the data directory of the source server, to
!         synchronize the target with. This option requires the source server
!         to be cleanly shut down.
         </para>
        </listitem>
       </varlistentry>
*************** PostgreSQL documentation
*** 135,142 ****
          Specifies a libpq connection string to connect to the source
          <productname>PostgreSQL</> server to synchronize the target with.
          The connection must be a normal (non-replication) connection
!         with superuser access. The server must be up and running,
!         and must not be in recovery mode.
         </para>
        </listitem>
       </varlistentry>
--- 135,142 ----
          Specifies a libpq connection string to connect to the source
          <productname>PostgreSQL</> server to synchronize the target with.
          The connection must be a normal (non-replication) connection
!         with superuser access. This option requires the server to be running
!         and not in recovery mode.
         </para>
        </listitem>
       </varlistentry>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Michael Paquier <[email-masked]>
Date: Sat, 18 Jun 2016 06:36:45 +0900

> I would like to apply this to 9.6.

What's the difference between "up and running" and "running"? I
thought that the current documentation was fine for this portion.
-- 
Michael

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 17 Jun 2016 18:03:14 -0400

> thought that the current documentation was fine for this portion.

I don't know what the difference between "up" and "running" is, so I
went with "running";  the original wording seemed to use two redundant
terms.

---

From: Michael Paquier <[email-masked]>
Date: Sat, 18 Jun 2016 08:26:30 +0900

> went with "running";  the original wording seemed to use two redundant

OK, no complains from here regarding this change then.
-- 
Michael

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 20 Jun 2016 11:09:34 -0400

> OK, no complains from here regarding this change then.

Patch applied.