Subject: gamke error -postgres9.4.5

From: [email-masked]
Date: Tue, 14 Jun 2016 12:12:57 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/8.3/static/libpq-build.html
Description:

utils/adt/xml.o: In function `pg_xml_done&#39;:
xml.c:(.text+0x13f5): undefined reference to `__xmlStructuredErrorContext&#39;
utils/adt/xml.o: In function `pg_xml_init&#39;:
xml.c:(.text+0x1c0d): undefined reference to `__xmlStructuredErrorContext&#39;
xml.c:(.text+0x1c26): undefined reference to `__xmlStructuredErrorContext&#39;
/usr/local/lib/libxml2.so: undefined reference to [email-masked]&#39;
collect2: ld returned 1 exit status
gmake[2]: *** [postgres] Error 1
gmake[2]: Leaving directory `/Data/postgresql-9.4.5/src/backend&#39;
gmake[1]: *** [all-backend-recurse] Error 2
gmake[1]: Leaving directory `/Data/postgresql-9.4.5/src&#39;
gmake: *** [all-src-recurse] Error 2

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Michael Paquier <[email-masked]>
Date: Tue, 14 Jun 2016 21:34:25 +0900

> Page: https://www.postgresql.org/docs/8.3/static/libpq-build.html

8.3 is out of support by community. And why are you pointing to this
page? This is libpq, and what is failing to compile is some backend
code.

> gmake: *** [all-src-recurse] Error 2

You had better review the shape of the objects in your version of this
libxml2 shared library, which is I imagine a custom build...
-- 
Michael

---

From: "Chelliah, Murugan (EXT - IN/Chennai)" <[email-masked]>
Date: Tue, 14 Jun 2016 12:43:32 +0000

Hi,

I am trying to install postgres9.4.5 version in one of the system with libxml, I ended with the below mentioned error.
While searching in google - I found the below page is somewhat relevant, so I just updated on that page. Can you please help me to resolve the below error OR Can you guide me the right person/forum/group to get the solution for this issue?
Thanks for your quick response. 
Let me know if any other details are required.

Thanks & Regards,
Murugan Chelliah
+91-7299080302

---

From: Tom Lane <[email-masked]>
Date: Tue, 14 Jun 2016 09:46:10 -0400

> xml.c:(.text+0x13f5): undefined reference to `__xmlStructuredErrorContext&#39;

This suggests that your libxml2 header files are of a newer version than
your libxml2 library (.so) is.

			regards, tom lane

---

From: "Chelliah, Murugan (EXT - IN/Chennai)" <[email-masked]>
Date: Wed, 15 Jun 2016 09:51:00 +0000

Hi, 

Can you please suggest/guide me the step by step instructions to resolve the issue.

I am trying to install postgres with libxml and with perl

Thanks & Regards,
Murugan Chelliah
+91-7299080302

-----Original Message-----
From: Tom Lane [mailto:[email-masked]] 
Sent: Tuesday, June 14, 2016 7:16 PM
To: Chelliah, Murugan (EXT - IN/Chennai) <[email-masked]>
Cc: [email-masked]
Subject: Re: [DOCS] gamke error -postgres9.4.5

			regards, tom lane