Subject: Manual Entries of commit_delay and commit_siblings are not complete.

From: Tianyin Xu <[email-masked]>
Date: Tue, 2 Oct 2012 17:36:28 -0700

Hi, pgsql-docs,

I was confused by the system behavior of PG's write ahead log, specifically
the relation between commit_delay, commit_siblings, and fsync.

Basically according to the manual (
http://www.postgresql.org/docs/9.1/static/runtime-config-wal.html), I know:

"commit_delay" specifies the delay before a transaction attempts to flush
the WAL buffer out to disk.
"commit_siblings" specifies minimum number of concurrent open transactions
to require before performing the commit_delay delay.

However, after looking at the code, I figured out these configuration
parameters are also controlled by fsync.

The only usage of the two parameter I can find is:

/* src/backend/access/transam/xact.c */

static TransactionId
RecordTransactionCommit(void)
     ...
     if (CommitDelay > 0 &&
                  enableFsync &&
                  MinimumActiveBackends(CommitSiblings))
            pg_usleep(CommitDelay);

    ...
}

where, CommitDelay stores the parameter of "commit_delay", CommitSiblings
stores the parameter of "commit_siblings", and enableFsync stores the
parameter of "fsync".

It seems the two parameters (commit_delay and commit_siblings) only have
effect when fsync is set to be *on*.

But, unfortunately, such behavior is not covered in the manual. The mistake
I made is only set the two values but disabling fsync so the expected PG
does not behave as I expected. I think it's definitely helpful to specify
the relations between these configuration parameters either in the manual,
or in the source code by giving warnings logs.

Thanks a lot!
Tianyin

-- 
Tianyin XU,
http://cseweb.ucsd.edu/~tixu/

---

From: Tianyin Xu <[email-masked]>
Date: Sat, 27 Oct 2012 18:16:34 -0700

Hi, pgsql-docs,

static TransactionId

    ...
}

Thanks a lot!
Tianyin

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 25 Jan 2013 15:54:28 -0500

On Tue, Oct  2, 2012 at 05:36:28PM -0700, Tianyin Xu wrote:
> Hi, pgsql-docs,
> 
> I was confused by the system behavior of PG's write ahead log, specifically the
> relation between commit_delay, commit_siblings, and fsync.
> 
> Basically according to the manual (http://www.postgresql.org/docs/9.1/static/
> runtime-config-wal.html), I know:
> 
> "commit_delay" specifies the delay before a transaction attempts to flush the
> WAL buffer out to disk.
> "commit_siblings" specifies minimum number of concurrent open transactions to
> require before performing the commit_delay delay.
> 
> stores the parameter of "commit_siblings", and enableFsync stores the parameter
> of "fsync".
> 
> It seems the two parameters (commit_delay and commit_siblings) only have effect
> when fsync is set to be *on*.
> 
> But, unfortunately, such behavior is not covered in the manual. The mistake I
> made is only set the two values but disabling fsync so the expected PG does not
> behave as I expected. I think it's definitely helpful to specify the relations
> between these configuration parameters either in the manual, or in the source
> code by giving warnings logs.

Docs updated for PG 9.3 with the attached patch.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +
diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
new file mode 100644
index 5f47c1f..19f513e
*** a/doc/src/sgml/config.sgml
--- b/doc/src/sgml/config.sgml
*************** include 'filename'
*** 1968,1974 ****
          the first process that becomes ready to flush waits for the configured
          interval, while subsequent processes wait only until the leader
          completes the flush.  The default <varname>commit_delay</> is zero
!         (no delay).
         </para>
        </listitem>
       </varlistentry>
--- 1968,1974 ----
          the first process that becomes ready to flush waits for the configured
          interval, while subsequent processes wait only until the leader
          completes the flush.  The default <varname>commit_delay</> is zero
!         (no delay), and only honored if <varname>fsync</varname> is enabled.
         </para>
        </listitem>
       </varlistentry>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs