Subject: Misc typos in documentation

From: Liudmila Mantrova <[email-masked]>
Date: Tue, 19 Jun 2018 10:46:17 +0300

Hi,

Please consider these small patches that fix a couple of typos in 
documentation.

I have split them in two just in case rn-typos.patch conflicts with any 
current work on release-11.sgml, which seems to be going on in more than 
one thread. I'll appreciate your feedback if it should have been done 
differently.

-- 
Liudmila Mantrova
Technical writer at Postgres Professional: http://www.postgrespro.com
The Russian Postgres Company

diff --git a/doc/src/sgml/cube.sgml b/doc/src/sgml/cube.sgml
index e010305..c6e5862 100644
--- a/doc/src/sgml/cube.sgml
+++ b/doc/src/sgml/cube.sgml
@@ -190,7 +190,7 @@
         n = 2 * k - 1 means lower bound of <replaceable>k</replaceable>-th
         dimension, n = 2 * k means upper bound of
         <replaceable>k</replaceable>-th dimension.  Negative
-        <replaceable>n</replaceable> denotes inversed value of corresponding
+        <replaceable>n</replaceable> denotes the inverse value of the corresponding
         positive coordinate.  This operator is designed for KNN-GiST support.
       </entry>
      </row>
diff --git a/doc/src/sgml/pgtrgm.sgml b/doc/src/sgml/pgtrgm.sgml
index 42e2426..83b0033 100644
--- a/doc/src/sgml/pgtrgm.sgml
+++ b/doc/src/sgml/pgtrgm.sgml
@@ -168,15 +168,15 @@
    greatest similarity between the first string and any substring of the second
    string.  However, this function does not add padding to the boundaries of
    the extent.  Thus, the number of additional characters present in the
-   second string is not considered, except for the mismatched word boundry.
+   second string is not considered, except for the mismatched word boundaries.
   </para>
 
   <para>
    At the same time, <function>strict_word_similarity(text, text)</function>
-   selects extent of words in the second string.  In the example above,
+   selects an extent of words in the second string.  In the example above,
    <function>strict_word_similarity(text, text)</function> would select the
-   extent of single word <literal>'words'</literal>, whose set of trigrams is
-   <literal>{"  w"," wo","wor","ord","rds","ds "}</literal>
+   extent of a single word <literal>'words'</literal>, whose set of trigrams is
+   <literal>{"  w"," wo","wor","ord","rds","ds "}</literal>.
 
 <programlisting>
 # SELECT strict_word_similarity('word', 'two words'), similarity('word', 'words');
diff --git a/doc/src/sgml/ref/pgbench.sgml b/doc/src/sgml/ref/pgbench.sgml
index 7bd01a2..7f92c77 100644
--- a/doc/src/sgml/ref/pgbench.sgml
+++ b/doc/src/sgml/ref/pgbench.sgml
@@ -1215,7 +1215,7 @@ pgbench <optional> <replaceable>options</replaceable> </optional> <replaceable>d
      </row>
      <row>
       <entry><literal>-</literal></entry>
-      <entry>substraction</entry>
+      <entry>subtraction</entry>
       <entry><literal>3 - 2.0</literal></entry>
       <entry><literal>1.0</literal></entry>
      </row>
diff --git a/doc/src/sgml/release-11.sgml b/doc/src/sgml/release-11.sgml
index 7599c6f..f2bddb5 100644
--- a/doc/src/sgml/release-11.sgml
+++ b/doc/src/sgml/release-11.sgml
@@ -1083,7 +1083,7 @@ same commits as above
 -->
 
        <para>
-        Allow vacuum to avoid unnecesary index scans (Masahiko Sawada,
+        Allow vacuum to avoid unnecessary index scans (Masahiko Sawada,
         Alexander Korotkov)
        </para>
       </listitem>
@@ -1594,7 +1594,7 @@ same commits as above
 -->
 
        <para>
-        Allow replication slots to be advanced programatically, rather
+        Allow replication slots to be advanced programmatically, rather
         than be consumed by subscribers (Petr Jelinek)
        </para>
 
@@ -1704,7 +1704,7 @@ same commits as above
 
        <para>
         Allow <command>ALTER INDEX</command> to set statistics-gathering
-        targets for expression indexes (Alexander Korotkov, Adrien nayrat)
+        targets for expression indexes (Alexander Korotkov, Adrien Nayrat)
        </para>
 
        <para>

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 20 Jun 2018 16:04:24 +0200

> one thread. I'll appreciate your feedback if it should have been done

Hi!

These all look good to me. Thanks, applied!

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>

---

From: Liudmila Mantrova <[email-masked]>
Date: Thu, 16 Aug 2018 11:25:25 +0300

On 06/20/2018 05:04 PM, Magnus Hagander wrote:
>
>
> On Tue, Jun 19, 2018 at 9:46 AM, Liudmila Mantrova 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     I have split them in two just in case rn-typos.patch conflicts
>     with any current work on release-11.sgml, which seems to be going
>     on in more than one thread. I'll appreciate your feedback if it
>     should have been done differently.
>
>
> Hi!
>

I have bumped into a couple of similar typos in 9.6 and 10 - the patch 
based on REL9_6_STABLE is attached.

diff --git a/doc/src/sgml/pgtrgm.sgml b/doc/src/sgml/pgtrgm.sgml
index 350da77..1de337a 100644
--- a/doc/src/sgml/pgtrgm.sgml
+++ b/doc/src/sgml/pgtrgm.sgml
@@ -143,7 +143,7 @@
    In the first string, the set of trigrams is
    <literal>{"  w"," wo","ord","wor","rd "}</literal>.
    In the second string, the ordered set of trigrams is
-   <literal>{"  t"," tw",two,"wo ","  w"," wo","wor","ord","rds", ds "}</literal>.
+   <literal>{"  t"," tw",two,"wo ","  w"," wo","wor","ord","rds","ds "}</literal>.
    The most similar extent of an ordered set of trigrams in the second string
    is <literal>{"  w"," wo","wor","ord"}</literal>, and the similarity is
    <literal>0.8</literal>.
@@ -154,7 +154,7 @@
    greatest similarity between the first string and any substring of the second
    string.  However, this function does not add padding to the boundaries of
    the extent.  Thus, the number of additional characters present in the
-   second string is not considered, except for the mismatched word boundry.
+   second string is not considered, except for the mismatched word boundaries.
   </para>
 
   <table id="pgtrgm-op-table">

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 25 Aug 2018 15:04:43 -0400

On Thu, Aug 16, 2018 at 11:25:25AM +0300, Liudmila Mantrova wrote:
>         current work on release-11.sgml, which seems to be going on in more
>         than one thread. I'll appreciate your feedback if it should have been
>         done differently.
> 
> I have bumped into a couple of similar typos in 9.6 and 10 - the patch based on
> REL9_6_STABLE is attached.

I have made the adjustments to 9.6 and 10 as you suggested.  I added
quoting to "two" to match other releases:

	https://git.postgresql.org/pg/commitdiff/993b5a78adff29fc58e7449cab98bb865b77c663

Thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +

---

From: Liudmila Mantrova <[email-masked]>
Date: Thu, 6 Sep 2018 18:45:29 +0300

> 	https://git.postgresql.org/pg/commitdiff/993b5a78adff29fc58e7449cab98bb865b77c663
Thank you, Bruce!

I totally missed those quotes (and your response).
I've just noticed your recent commit, and looks like the typo to be 
fixed ("boundries") managed to escape somehow.
Assuming it's not an alternative spelling I'm unaware of, I'm attaching 
a smaller version of the patch (based on the current state of 
REL_10_STABLE).

diff --git a/doc/src/sgml/pgtrgm.sgml b/doc/src/sgml/pgtrgm.sgml
index 8e50f79..edc0813 100644
--- a/doc/src/sgml/pgtrgm.sgml
+++ b/doc/src/sgml/pgtrgm.sgml
@@ -154,7 +154,7 @@
    greatest similarity between the first string and any substring of the second
    string.  However, this function does not add padding to the boundaries of
    the extent.  Thus, the number of additional characters present in the
-   second string is not considered, except for the mismatched word boundries.
+   second string is not considered, except for the mismatched word boundaries.
   </para>

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 6 Sep 2018 20:43:11 -0400

On Thu, Sep  6, 2018 at 06:45:29PM +0300, Liudmila Mantrova wrote:
> I've just noticed your recent commit, and looks like the typo to be fixed
> ("boundries") managed to escape somehow.
> Assuming it's not an alternative spelling I'm unaware of, I'm attaching a
> smaller version of the patch (based on the current state of REL_10_STABLE).

Oh, yes, I missed that.   Applied to PG 9.6 and 10, which is where they
were needed.  Thanks.