Subject: DTrace home page down

From: Peter Eisentraut <[email-masked]>
Date: Tue, 09 Apr 2013 23:30:38 -0400

Since OpenSolaris was yanked from the net, the DTrace link in our
documentation points to approximately nowhere.  I propose the attached
patch with a link to Wikipedia instead (for lack for strong
alternatives), and a few other updates.

diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgml
index c22f16a..b37b6c3 100644
--- a/doc/src/sgml/monitoring.sgml
+++ b/doc/src/sgml/monitoring.sgml
@@ -1814,14 +1814,12 @@ <title>Dynamic Tracing</title>
   </para>
 
   <para>
-   Currently, only the
-   <ulink url="http://opensolaris.org/os/community/dtrace/">DTrace</ulink>
-   utility is supported, which is available
-   on OpenSolaris, Solaris 10, and Mac OS X Leopard. It is expected that
-   DTrace will be available in the future on FreeBSD and possibly other
-   operating systems.  The
+   Currently, the
+   <ulink url="https://en.wikipedia.org/wiki/DTrace">DTrace</ulink>
+   utility is supported, which, at the time of this writing, is available
+   on Solaris, Mac OS X, FreeBSD, NetBSD, and Oracle Linux.  The
    <ulink url="http://sourceware.org/systemtap/">SystemTap</ulink> project
-   for Linux also provides a DTrace equivalent.  Supporting other dynamic
+   for Linux provides a DTrace equivalent and can also be used.  Supporting other dynamic
    tracing utilities is theoretically possible by changing the definitions for
    the macros in <filename>src/include/utils/probes.h</>.
   </para>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Scott Marlowe <[email-masked]>
Date: Tue, 9 Apr 2013 21:48:07 -0600

How about pointing it at http://dtrace.org/

-- 
To understand recursion, one must first understand recursion.

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 10 Apr 2013 11:04:36 +0200

>> alternatives), and a few other updates.

+1.

> How about pointing it at http://dtrace.org/

That seems to just be a blog aggregator? And most things on there now
aren't even about dtrace. So -1 for that, seems the wikipedia article
would be a better choice.

--
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/