Subject: Dead link in release notes for 19

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Mon, 27 Apr 2026 05:36:36 +0000

Hi,

in the release notes for 19 there is a dead link in section "E.1.3.2. Query Commands", first entry, first link:

https://postgr.es/c/2f094e7ac

Regards
Daniel

---

From: Laurenz Albe <[email-masked]>
Date: Mon, 27 Apr 2026 09:53:35 +0200

> https://postgr.es/c/2f094e7ac

Strange, the link works for me.
It points to commit 2f094e7ac691abc9d2fe0f4dcf0feac4a6ce1d9c.

Yours,
Laurenz Albe

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Mon, 27 Apr 2026 07:55:22 +0000

>It points to commit 2f094e7ac691abc9d2fe0f4dcf0feac4a6ce1d9c.

Yes, now it works. This morning it gave some XML error.

Regards
Daniel

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 27 Apr 2026 10:18:57 -0400

> Yes, now it works. This morning it gave some XML error.

When I clicked the link, the page errors,  but there's an error message 
at the top:

===
This page contains the following errors:
error on line 6484 at column 177: EntityRef: expecting ';'
Below is a rendering of the page up to the first error.
===

I think this may be an issue with gitweb?

Jonathan

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Mon, 27 Apr 2026 14:26:25 +0000

>>I think this may be an issue with gitweb?

Now it is back to not working, and this is what I get:

XML Parsing Error: unclosed token
Location: https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=2f094e7ac
Line Number 5231, Column 41:
<div class="diff ctx">&nbsp;&nbsp;&nbsp;&nb
----------------------------------------^

Regards
Daniel

Jonathan

---

From: Tom Lane <[email-masked]>
Date: Mon, 27 Apr 2026 10:37:23 -0400

> I think this may be an issue with gitweb?

Yeah, I got a rendering error too (yet a different one).  I think that
commit is so large that we're running into browser rendering engine
bugs.  Or maybe gitweb is failing to send it all.

			regards, tom lane

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 27 Apr 2026 18:29:53 +0200

> bugs.  Or maybe gitweb is failing to send it all.
It's working right now, but next time it fails, if someone can check with a
view source or similar if it happens to be that gitweb just cut off the
outputsomewhere in th emiddle without finishing it. That is, if it is a
HTML page but doesn't go all the way to </html>.

//Magnus

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Tue, 28 Apr 2026 03:42:33 +0000

Hi Magnus,

>It's working right now, but next time it fails, if someone can check with a view source or similar if it happens to be that >gitweb just cut off the outputsomewhere in th emiddle without finishing it. That is, if it is a HTML page but doesn't go all >the way to </html>.

... this is how the page ends when it is not working (Browser is Firefox):

<div class="patch" id="patch90">
<div class="diff header">diff --git <a class="path" href="/gitweb/?p=postgresql.git;a=blob;f=src/include/parser/analyze.h;h=abc5f11cafd6655c57e77f4cac7522ad6a1ed4b1">a/src/include/parser/analyze.h</a> <a class="path" href="/gitweb/?p=postgresql.git;a=blob;f=src/include/parser/analyze.h;h=e10270ff0ffdedc9cc1e713c5b1431558cc594ca;hb=2f094e7ac">b/src/include/parser/analyze.h</a></div>
<div class="diff extended_header">
index abc5f11cafd6655c57e77f4cac7522ad6a1ed4b1..e10270ff0ffdedc9cc1e713c5b1431558cc594ca 100644<span class="info"> (file)</span><br/>
</div>
<div class="diff from_file">--- a/<a class="path" href="/gitweb/?p=postgresq

Regards
Daniel